Do Not Sell My Personal Information Jump to content

1993 Ls No Turn Signals Or Hazards, Help!


nolyaw
 Share

Recommended Posts

I have a 1993 LS, and I have no turn signals. No arrows on the dash, no clicking, nothing. No hazards either. The Hazard triangle on the button is not lit up either. The fuse is good, for both the hazards and the turn signals. I am getting 12V to ground from the fuse block. I have all of my tailights and brake lights, so I don't believe its a wiring harness issue. Any one had this problem? I tried a search and could find very little. Any input would be helpful.

Link to comment
Share on other sites

I have a 1993 LS, and I have no turn signals. No arrows on the dash, no clicking, nothing. No hazards either. The Hazard triangle on the button is not lit up either. The fuse is good, for both the hazards and the turn signals. I am getting 12V to ground from the fuse block. I have all of my tailights and brake lights, so I don't believe its a wiring harness issue. Any one had this problem? I tried a search and could find very little. Any input would be helpful.

Sounds like its the flasher unit itself.... I am pretty sure all cars have them, but I am not sure of the location on the LS. I would check the owners manual to be sure.

Link to comment
Share on other sites

I have a 1993 LS, and I have no turn signals. No arrows on the dash, no clicking, nothing. No hazards either. The Hazard triangle on the button is not lit up either. The fuse is good, for both the hazards and the turn signals. I am getting 12V to ground from the fuse block. I have all of my tailights and brake lights, so I don't believe its a wiring harness issue. Any one had this problem? I tried a search and could find very little. Any input would be helpful.

Sounds like its the flasher unit itself.... I am pretty sure all cars have them, but I am not sure of the location on the LS. I would check the owners manual to be sure.

Well, if the flasher was bad, I would still have arrows on the dash, and the light lit up on the car. I have no lights, no arrows, nothing.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership