Do Not Sell My Personal Information Jump to content

Brothers '95 Sc400 Lost Steering


helpcomputer
 Share

Recommended Posts

A few weeks ago my brothers 'new' 95 SC400 lost its steering, ok, checked the belt, replaced. tightened tensioner. checked power steering fluid, looks a little goopy brown... like the stuff in the valve covers on my 350 vortec when my intake manifold gasket went. PS pump doesnt make any noise when turning the wheel. no CEL. is this a normal problem in these cars? thanks for your help.

Link to comment
Share on other sites


A few weeks ago my brothers 'new' 95 SC400 lost its steering, ok, checked the belt, replaced. tightened tensioner. checked power steering fluid, looks a little goopy brown... like the stuff in the valve covers on my 350 vortec when my intake manifold gasket went. PS pump doesnt make any noise when turning the wheel. no CEL. is this a normal problem in these cars? thanks for your help.

steering rack may be toast.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership