Sign in to follow this  
frblexus

1993 Sc400 - Heater Won't Blow Warm Air

Recommended Posts

I have a 1993 SC400. My heater will blow but not warm air. Is there a heat control valve that I can check/replace or should I be looking for trouble someplace else ?????? Is it controlled by a fuse or what ??

Share this post


Link to post
Share on other sites
I have a 1993 SC400. My heater will blow but not warm air. Is there a heat control valve that I can check/replace or should I be looking for trouble someplace else ?????? Is it controlled by a fuse or what ??

Are you getting Hot air when your in Motion?

There is a heater duct valve that's controlled by your Climate Control. Look for something on the Pass-side midrange engine bay for that. You should be able to manually open the cover.

Share this post


Link to post
Share on other sites
I have a 1993 SC400. My heater will blow but not warm air. Is there a heat control valve that I can check/replace or should I be looking for trouble someplace else ?????? Is it controlled by a fuse or what ??

Change your thermostat

Share this post


Link to post
Share on other sites
I have a 1993 SC400. My heater will blow but not warm air. Is there a heat control valve that I can check/replace or should I be looking for trouble someplace else ?????? Is it controlled by a fuse or what ??

Are you getting Hot air when your in Motion?

There is a heater duct valve that's controlled by your Climate Control. Look for something on the Pass-side midrange engine bay for that. You should be able to manually open the cover.

No, I don't get hot air when in motion. I changed the thermostat like SeanGrac said. It made no difference. I am now looking for the heater valve, with no success. Is it on the firewall section (passenger side) or on the fender weld (passenger side) ????? I've checked all fuses and they look good. Still stuck !!!!!! Thanks

Share this post


Link to post
Share on other sites
I have a 1993 SC400. My heater will blow but not warm air. Is there a heat control valve that I can check/replace or should I be looking for trouble someplace else ?????? Is it controlled by a fuse or what ??

Try the self diagnostic for the a/c. I can't remember the buttons that you have to push; but they are on the ac control panel. Its like the "recirc" and off buttons at the same time. Anyway, my local library has 'Mitchell's' online. Try yours. If it's not free; it's cheap.

P.S. I am assuming that you have plenty of coolant in. If the comes on it needs more.

Share this post


Link to post
Share on other sites
I have a 1993 SC400. My heater will blow but not warm air. Is there a heat control valve that I can check/replace or should I be looking for trouble someplace else ?????? Is it controlled by a fuse or what ??

Are you getting Hot air when your in Motion?

There is a heater duct valve that's controlled by your Climate Control. Look for something on the Pass-side midrange engine bay for that. You should be able to manually open the cover.

No, I don't get hot air when in motion. I changed the thermostat like SeanGrac said. It made no difference. I am now looking for the heater valve, with no success. Is it on the firewall section (passenger side) or on the fender weld (passenger side) ????? I've checked all fuses and they look good. Still stuck !!!!!! Thanks

i have one for sale 40 shipped to your door. paypal is gazi_ali@hotmail.com

Share this post


Link to post
Share on other sites
I have a 1993 SC400. My heater will blow but not warm air. Is there a heat control valve that I can check/replace or should I be looking for trouble someplace else ?????? Is it controlled by a fuse or what ??

Are you getting Hot air when your in Motion?

There is a heater duct valve that's controlled by your Climate Control. Look for something on the Pass-side midrange engine bay for that. You should be able to manually open the cover.

No, I don't get hot air when in motion. I changed the thermostat like SeanGrac said. It made no difference. I am now looking for the heater valve, with no success. Is it on the firewall section (passenger side) or on the fender weld (passenger side) ????? I've checked all fuses and they look good. Still stuck !!!!!! Thanks

i have one for sale 40 shipped to your door. paypal is gazi_ali@hotmail.com

HAS ANY been able to resolve this heater issue, I have the same problem but dealer price was too much, and they did not show me the location. Who can assist me with this and who has had the problem fixed

Share this post


Link to post
Share on other sites

It was mentioned above, but anyone suffering from a lack of heat make certain your coolant is topped off. When my level dips by even an inch heat is virtually unavailable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this