Sign in to follow this  
stockplayerz

Help! New To The Forum

Recommended Posts

hello, i am new to this forum and came in search for some help. i have a 99 lexus rx300 that suddenly won't blow cold nor hot air. i don't hear the fan turning on at all. it was working fine up till now. what are the things that i can check myself before taking it to the dealer? is there a fuse of some sort? or a computer reset? or...? please advise. thanks. mike

Share this post


Link to post
Share on other sites

Mike,

It would be a good idea to check your fuses first. I am certain there is a blower motor fuse. Look for it and I would guess that it could be blown. If not, the actual motor may be out. It is not too difficult of a fix if you are somewhat handy and can turn a screw driver and wrench. You can probably search the forum for similiar problems and answers. Hope this helps.

Share this post


Link to post
Share on other sites
Mike,

It would be a good idea to check your fuses first. I am certain there is a blower motor fuse. Look for it and I would guess that it could be blown. If not, the actual motor may be out. It is not too difficult of a fix if you are somewhat handy and can turn a screw driver and wrench. You can probably search the forum for similiar problems and answers. Hope this helps.

thanks for the reply. if anyone has any specifics of where i can check for the fuse, please let me know. thanks.

Share this post


Link to post
Share on other sites
hello, i am new to this forum and came in search for some help. i have a 99 lexus rx300 that suddenly won't blow cold nor hot air. i don't hear the fan turning on at all. it was working fine up till now. what are the things that i can check myself before taking it to the dealer? is there a fuse of some sort? or a computer reset? or...? please advise. thanks. mike

I would first pull the battery cable for a few minutes to reset all the electronics. This may get things going.

Share this post


Link to post
Share on other sites
Mike,

It would be a good idea to check your fuses first. I am certain there is a blower motor fuse. Look for it and I would guess that it could be blown. If not, the actual motor may be out. It is not too difficult of a fix if you are somewhat handy and can turn a screw driver and wrench. You can probably search the forum for similiar problems and answers. Hope this helps.

thanks for the reply. if anyone has any specifics of where i can check for the fuse, please let me know. thanks.

The fuse box is just to the left of the steering wheel. There is a small flip down compartment. The fuses are located behind this compartment. On the back side of the detachable compartment there is a list of the fuses. look for the blower fuse or the heater fuse. Hope this helps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this