Sign in to follow this  
eds92sc

Engine Suddenly Died On Freeway, Cranks But Won't Restart

Recommended Posts

SOMEBODY HELP.

I was driving my 92 sc400 at 70mph on the freeway, and it suddenly quit on me. I pulled over to the shoulder, and tried to restart the engine with no luck, even after waiting 30 min. The engine will turn, but I don't get anything else. The car has 101,000 miles, and nowadays hardly gets driven. Any place I can start at. I don't have an OBD reader handy, so I can't plug into the computer for any fault codes at this time. The car was running just fine until this happened.

Share this post


Link to post
Share on other sites
SOMEBODY HELP.

I was driving my 92 sc400 at 70mph on the freeway, and it suddenly quit on me. I pulled over to the shoulder, and tried to restart the engine with no luck, even after waiting 30 min. The engine will turn, but I don't get anything else. The car has 101,000 miles, and nowadays hardly gets driven. Any place I can start at. I don't have an OBD reader handy, so I can't plug into the computer for any fault codes at this time. The car was running just fine until this happened.

I had the same problem althought luckily for me i was going about 25, but my problem was the fuel injector was clogged, i have 102,000 miles on mine. When the fuel pumps were replaced, the car has run fine ever since. Hope this helps, but def take it to a shop an have them check the injector and pumps

Share this post


Link to post
Share on other sites

try do a search on fuel pump computer or how to bypass the fuel pump computer and see if the fuel pump turns on or not.

Share this post


Link to post
Share on other sites
SOMEBODY HELP.

I was driving my 92 sc400 at 70mph on the freeway, and it suddenly quit on me. I pulled over to the shoulder, and tried to restart the engine with no luck, even after waiting 30 min. The engine will turn, but I don't get anything else. The car has 101,000 miles, and nowadays hardly gets driven. Any place I can start at. I don't have an OBD reader handy, so I can't plug into the computer for any fault codes at this time. The car was running just fine until this happened.

Can you better explain what you were doing, and what happened when you were driving @ 70mph? also is the check engine light on, and did you or anyone else work on the car recently.

Share this post


Link to post
Share on other sites
SOMEBODY HELP.

I was driving my 92 sc400 at 70mph on the freeway, and it suddenly quit on me. I pulled over to the shoulder, and tried to restart the engine with no luck, even after waiting 30 min. The engine will turn, but I don't get anything else. The car has 101,000 miles, and nowadays hardly gets driven. Any place I can start at. I don't have an OBD reader handy, so I can't plug into the computer for any fault codes at this time. The car was running just fine until this happened.

Can you better explain what you were doing, and what happened when you were driving @ 70mph? also is the check engine light on, and did you or anyone else work on the car recently.

I have not recently had any work done. The power steering pump was replaced about 2000 miles ago. Besides that, the car is a weekend car, and gets driven once or twice a week. When the car quit, I was cruising along on the fwy down a slight incline. When I pressed my gas pedal, nothing happened, and I thought maybe my tranny went bad. I shifted the tranny gears to 2 and N before I realized the engine quit and I did see a light on the dash come on. I had a lot going on at the time, and I think I only saw the "check engine" light come on. I'm not sure if any other lights came on. I was too busy trying to get to the side of the road. The only other thing I can think of is that I just filled up the tank about 25-30 miles before the eng quit. Not sure if it was related. I filled up at Shell.

Share this post


Link to post
Share on other sites
SOMEBODY HELP.

I was driving my 92 sc400 at 70mph on the freeway, and it suddenly quit on me. I pulled over to the shoulder, and tried to restart the engine with no luck, even after waiting 30 min. The engine will turn, but I don't get anything else. The car has 101,000 miles, and nowadays hardly gets driven. Any place I can start at. I don't have an OBD reader handy, so I can't plug into the computer for any fault codes at this time. The car was running just fine until this happened.

Can you better explain what you were doing, and what happened when you were driving @ 70mph? also is the check engine light on, and did you or anyone else work on the car recently.

I have not recently had any work done. The power steering pump was replaced about 2000 miles ago. Besides that, the car is a weekend car, and gets driven once or twice a week. When the car quit, I was cruising along on the fwy down a slight incline. When I pressed my gas pedal, nothing happened, and I thought maybe my tranny went bad. I shifted the tranny gears to 2 and N before I realized the engine quit and I did see a light on the dash come on. I had a lot going on at the time, and I think I only saw the "check engine" light come on. I'm not sure if any other lights came on. I was too busy trying to get to the side of the road. The only other thing I can think of is that I just filled up the tank about 25-30 miles before the eng quit. Not sure if it was related. I filled up at Shell.

My steering had went out to and i had my foot on the gas and i was going backwards, the mechanics couldnt find anything wrong with it, an jus said it was a faulty fuel gauge, they had it replaced and filled her up and the problem persisted as you have described...you know what you need to have checked, since most mechanics will not think to look at the fuel pumps unfortunately.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this