Jump to content


Power Steering


Canopy
 Share

Recommended Posts

My wife's 96 LS400 has developed a whining/buzzing sound which appears to be related to power steering. Took it in to local Toyota dealer (no Lexus dealer here) and they diagnosed a leaking high pressure hose on power steering system. $500 later, took the car home, noise was better, but still there. That was 6 weeks ago. Now noise is getting louder, is whining/buzzing (hard to describe) all the time, but changes pitch when turning wheels.

I'm going back to the Toyota dealer (usually good service, but might have missed this one) soon, but want some ideas from the forum. If it's the pump, how much are we talking about - ball park? Could it be something less than the pump?

Thanks in advance.

Link to comment
Share on other sites


Looks like they did not bleed the system correctly or your pump is on the way out. Check fluid levels are correct and no leaks anywhere. Turn on the car loosen the PS cap( making sure is not that loose that it falls in the running engine, just loose enough to bleed the air out), and turn the wheels. Turn the wheels at least 30 times in each direction to make sure the air is out, then place the cap back. If the noise does not stop you may have wrong fluid, bad pump, bad rack etc. Mine car was diagnosed with a bad pressure line, a bad rack and does not make any noise. It leaks little if leaking.

CPR

Link to comment
Share on other sites

My wife's 96 LS400 has developed a whining/buzzing sound which appears to be related to power steering. Took it in to local Toyota dealer (no Lexus dealer here) and they diagnosed a leaking high pressure hose on power steering system. $500 later, took the car home, noise was better, but still there. That was 6 weeks ago. Now noise is getting louder, is whining/buzzing (hard to describe) all the time, but changes pitch when turning wheels.

I'm going back to the Toyota dealer (usually good service, but might have missed this one) soon, but want some ideas from the forum. If it's the pump, how much are we talking about - ball park? Could it be something less than the pump?

Thanks in advance.

They need to remove the steering solenoid and clean the filter. The system will have a siphoning problem if the filter is dirty/blocked...

Link to comment
Share on other sites

  • 3 weeks later...
My wife's 96 LS400 has developed a whining/buzzing sound which appears to be related to power steering. Took it in to local Toyota dealer (no Lexus dealer here) and they diagnosed a leaking high pressure hose on power steering system. $500 later, took the car home, noise was better, but still there. That was 6 weeks ago. Now noise is getting louder, is whining/buzzing (hard to describe) all the time, but changes pitch when turning wheels.

I'm going back to the Toyota dealer (usually good service, but might have missed this one) soon, but want some ideas from the forum. If it's the pump, how much are we talking about - ball park? Could it be something less than the pump?

Thanks in advance.

As someone else suggested ... kinda sounds like the power steering pump ... BUT .... have you cleaned the Power Steering Solenoid Filter yet? You can do a search for that here .... that little filter is probably clogged, thus causing very high system pressure. It is fairly simple to remove and clean .... I found photos here at "the club" ... took them to my independent mechanic who did the work for me for about $100 which included an entire system flush ..... Up to this point in time, my high pressure line was "sweating" fluid ..... but after we cleaned the solenoid filter, all the sweating has stopped. My steering rack was sweating fluid also ... but that has stopped and my steering system has been working fine since servicing this little filter ..... you should really check it out ...

hope everything works out for you on this .... (^-^)

Link to comment
Share on other sites

It is your pump the system naturally will get rid of air all by itself, it may have a plugged screen on the solenoid though as the high pressure pushing through a blockage would make noise. The new fluid they added with the line would have broken down some of the dirt but it jsut clogged up again.

Link to comment
Share on other sites

It is your pump the system naturally will get rid of air all by itself, it may have a plugged screen on the solenoid though as the high pressure pushing through a blockage would make noise. The new fluid they added with the line would have broken down some of the dirt but it jsut clogged up again.

Only air in the system !!

i have this last week, it's over now, so, lexus dealer say it's the pump...

Only air in the system, see my question in the forum.

regards

ge3op643.jpg

Link to comment
Share on other sites


  • 2 weeks later...

Thanks all who responded. The Toyota dealer replaced the pump, and $900 later it works fine. They may have cleaned/replaced the filter at the same time, as some of you suggested. At any rate, it's fixed.

I appreciate your responses.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership