Sign in to follow this  
jeremyp

Check Out My System Upgrade!

Recommended Posts

This is phase 2 of my system upgrade. Phase 1 included the installation of a JL Audio 10W0 sub powered by a Kicker 150.2 2ch amp, MTX Thunder 8000 5.25" components up front and Infinity Reference 652i coaxials in rear powered by a Sony XPlod 1505SX (had it laying around).

Now for the fun part! For phase 2 I replaced the 10W0 with a 10W3 in a custom enclosure made by a local shop (check out the pics) and replaced the MTX components with a set of CDT Audio CL-61a's. Man, it sounds killer now! Even with a Sony amp!

Whatcha think?

Here's the custom enclosure

post-11-1062826779.jpg

Share this post


Link to post
Share on other sites

I have 2 12 inch pioneer impp 450 subs with a 400 fostgate amp. My problem is it sounds like crap. How i can i get it hooked up to sound good. The subs sound distorted but they aren't blown. The place that installed them said that is typical with rx300's. Help! IYZ

Share this post


Link to post
Share on other sites

im guessing the box there in sucks for your type of car!are they in a ported or sealed box?a bandpass might be better for you if you have a rx and theres no trunk.a bandpass will give you more bass in your situation i think.

Share this post


Link to post
Share on other sites
CDT Audio mid mounted in a custome speaker bracket I had to make out of 3/4 MDF

all looks good! :D

Share this post


Link to post
Share on other sites
I have 2 12 inch pioneer impp 450 subs with a 400 fostgate amp. My problem is it sounds like crap. How i can i get it hooked up to sound good. The subs sound distorted but they aren't blown. The place that installed them said that is typical with rx300's. Help! IYZ

i forgot one more thing!check the speaker lines again and make sure positive and negitive is hooked up right!when i say check i mean even take the speakers out and check the wires and follow them and make sure there all correct because that also will make it sounds bad if there crossed

Share this post


Link to post
Share on other sites

I have 2 12 inch pioneer impp 450 subs with a 400 fostgate amp. My problem is it sounds like crap. How i can i get it hooked up to sound good. The subs sound distorted but they aren't blown. The place that installed them said that is typical with rx300's. Help! IYZ

Try turning the box to face the rear seats. This will stop the rear hatch door from rattling so much and give you a tad bit less bass, but not that noticable. I also strongly recommend dynamat extreme in the rear hatch door and anywhere else you may get some rattling. I plan on doing the entire doors instead of the just the speaker areas as shown in the pic. What a difference.

Do what BBSAL said above. Also, How is the input of the amp wired? Did they take the existing sub speaker wires and run them directly to the amp's high level inputs or did they use a Line Output convertor and then RCAs into the amp? If they did use a LOC, then what brand/model did they use? It is very important to use a high quality, adjustable LOC in this application to keep noise to a minimum. I recommend AudioLink PL2 from crutchfield.

If you don't know any of the answers, then call your installer to get the details of how your stuff was installed.

DO NOT take his answer as acceptable! My system ROCKS now and no distortion at all and I have a crappy Sony XPlod amp running my speakers. Although I have an Eclipse PA5422 coming in this week to replace it.

JP

Share this post


Link to post
Share on other sites

:cheers: Your car looks Awesome, congratulations on that well done job :cheers:

:unsure: Would be nice to know the year and model of the car. It appears to be late 2001 RX 300s ..... Guessing :unsure:

:ph34r: welgaby@msn.com :ph34r:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this