Jump to content


Blinker Works, Parking Light Doesn't


 Share

Recommended Posts

92 es300...my right headlight had condensation in it so took it out put a capful of rubbing alcohol in and blowdryed it out. put the turn signal back in and it was out. shimmied the bulb around a bit and the blinker works now, but when i switch it to just parking lights, or with the headlights (low or highbeam) it doesnt light up. it's clipped in properly and obviously theres power going to it, as i get a turn signal. any suggestions?

Link to comment
Share on other sites


92 es300...my right headlight had condensation in it so took it out put a capful of rubbing alcohol in and blowdryed it out. put the turn signal back in and it was out. shimmied the bulb around a bit and the blinker works now, but when i switch it to just parking lights, or with the headlights (low or highbeam) it doesnt light up. it's clipped in properly and obviously theres power going to it, as i get a turn signal. any suggestions?

The turn signal bulb and parking light bulb are one in the same. They have two filaments that operate from different parts of the cars circuitry.

I suggest you buy a new bulb, clean out the socket( there might be oxidation), and see if that works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership