Sign in to follow this  
BrostyDawg

2000 Gs 300 Transmission Problem

Recommended Posts

I have a 2000 GS 300 WITH 150,000 miles on it. I had the tranny flushed at 70,000 and 140,000. The last 10,000 miles I noticed the transmission when descending in a parking ramp and letting off the gas it would jerk and feel like a brake is being applied and then released. It also does this in other declines but only when in first gear.

Is this a solenoid issue or is the tranny starting to fail?

Share this post


Link to post
Share on other sites
 

I have a 2000 GS 300 WITH 150,000 miles on it. I had the tranny flushed at 70,000 and 140,000. The last 10,000 miles I noticed the transmission when descending in a parking ramp and letting off the gas it would jerk and feel like a brake is being applied and then released. It also does this in other declines but only when in first gear.

Is this a solenoid issue or is the tranny starting to fail?

I don't know about your dealership but mine doesn't charge to take a look at your car. Let them find the problem for you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this