Jump to content


My New 94 Ls 400 And A Few Questions


wrpsuite
 Share

Recommended Posts

Picked up this LS 400 anniversary in metallic white with 180k from my brother in law yesterday. He stepped up to the 460 which seems to be as close to perfection as a car gets.

Anyways there are a few things going on with the car I'd like to get input on. The car runs and rides teriffic has been to the dealer for every service and never abused, it has been garaged since new and looks like new with the exception of a wear spot on one seat and the drivers seat padding is a little worn.

1: Driver seatbelt extended all the way and will not retract?

2: Dashboard is dark when starting in cold and comes on once warm?

3: Gas guage reads empty until 10 minutes after driving and it functions properly (i think)?

4: Heated seats don't seem to warm up but it's been cold and I'll have to test that further soon.. How hot should htey get and how fast?

5: On dash there is what looks like a warning light that says "trac" I turned trac on and off but it stays lit, is this normal or showing some failure?

lastly , where can I get some of those clear turn signal lenses so I can ditch the orange ones?

Any comments are appreciated, thanks!

Link to comment
Share on other sites


The dash lighting issues are discussed at length in this forum. As well as the gas gauge problem. Well known 1st gen Lexus deficiency that they won't acknowledge. I had Jim Walker fix my problems for $225 total. Do a search for him in this forum. Couldn't be happier. Best of luck.

TxLex

Link to comment
Share on other sites

1: Driver seatbelt extended all the way and will not retract?

2: Dashboard is dark when starting in cold and comes on once warm?

3: Gas guage reads empty until 10 minutes after driving and it functions properly (i think)?

4: Heated seats don't seem to warm up but it's been cold and I'll have to test that further soon.. How hot should htey get and how fast?

5: On dash there is what looks like a warning light that says "trac" I turned trac on and off but it stays lit, is this normal or showing some failure?

lastly , where can I get some of those clear turn signal lenses so I can ditch the orange ones?

Any comments are appreciated, thanks!

1. Saw a very detailed post on the retractor Here. Haven't had the opportunity to try it myself yet.

2 & 3. For the Instrument panel look Here.

5. Posts have stated that a poor or dying battery can trigger the TRAC light. If battery replacement fails to resolve do a search on TRAC here and you will find numerous posts.

Lastly. Lenses are available Here and on eBay. Tutorial is Here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership