Do Not Sell My Personal Information Jump to content

The Car Runs But There's No Power


mktbully
 Share

Recommended Posts

at idle the car runs perfectly fine.

when i try to rev it at idle it goes up to around 1K and then the tach falls if i try to rev it farther. after i release the gas the tach bounces back up to the idle speed. i did the tune up and that didn't solve anything.

now when driving...if i step on the gas hard it doesn't feel like there's any power. if i lightly hit the gas and pretty much stay below that 1K mark then it drives fine...slow but fine.

i can pretty much rev the car at idle w/o a problem but the tach is pegged at 0.

i've replaced the caps, rotors, plugs, air filter, the TB looks clean, also replaced the MAF.

what else can it be? there's a faint gas smell in the exhaust but i'm thinking it doesn't smell THAT bad. oh and when i pulled the plugs one plug was wet with gas. this also started when the recent cold snap in NYC.

what else can it be?

timing belt slip? it looks ok when i took the upper covers off

coils?

TPS?

the car is a 92 SC400

i hate to give up on this car.

any suggestions?

Thanks for reading. any help would be greatly appreciated.

Link to comment
Share on other sites


with a little search on this forum i saw a few threads about ignition coil.

well guess what...it was the coil.

good part is the car needed a tune up anyway...now the car really hauls !Removed!.

hope someone reads this thread in the future and it may help someone else out.

thanks!

Link to comment
Share on other sites

with a little search on this forum i saw a few threads about ignition coil.

well guess what...it was the coil.

good part is the car needed a tune up anyway...now the car really hauls !Removed!.

hope someone reads this thread in the future and it may help someone else out.

thanks!

Hi,

Did it suddenly lose power or was it gradual? Also, did the steering wheel suddenly feel a little stiff? Just curious... Did you have to change ALL the coils?

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership