Do Not Sell My Personal Information Jump to content

Recommended Posts

I have a 92 SC400 and the damn idiot light to fill up the coolant always comes on. It comes on guaranteed if i drive the car long enough to get the coolant fully flowing. The light means that you need to top off the coolant however my coolant is completly full and does not need any more. I have checked several times and it is always full. Any ideas on this? Bad sensor? Problem in coolant system?

Link to post
Share on other sites

I've got the same problem ('93 SC4). And it did turn out to be the sensor. Let me know if you find one somewhere other than the dealer, because i've simply given up trying to find one aftermarket. The sensor is $100 at the stealership. If the light really bothers you, you can just disconect the wire harness to the sensor until you get the replacement one.

Link to post
Share on other sites

Ok so I checked my coolant right after driving for about 30 minutes and coolant is bubling up from where the sensor is located. This could be because I added to much coolant but it still should not bubble up from under the sensor. Would replacing the sensor fix this?

Link to post
Share on other sites

I have a 92 SC400 and the damn idiot light to fill up the coolant always comes on. It comes on guaranteed if i drive the car long enough to get the coolant fully flowing. The light means that you need to top off the coolant however my coolant is completly full and does not need any more. I have checked several times and it is always full. Any ideas on this? Bad sensor? Problem in coolant system?

-------------------------------------------------------------------------------------------------------------

I had a similar problem w my 93 sc400. The light would come on intermittently mostly when I would

change elevation like going downhill.

I checked my coolant level and thought it was full but added maybe a half quart just to make sure and

the problem went away immediately. Apparently the sensor is very sensitive.

L

Link to post
Share on other sites

Update: I removed my coolant level sensor(coolant seems to be seeping out from under it when very hot). The o-ring looks to be in good shape. The orange floatation device on the coolant level sensor is cracked all the way through but looks to me like it would still work fine. I filled up the coolant to overflowing and light still lights. I am assuming the crack in the floating part of the sensor is causing it to be bad.

Link to post
Share on other sites

If the float is cracked, use some epoxy to seal it back up. Use as little as possible to seal the crack as a thick layer of epoxy could add enough weight to make it read false.

There must be coolant in the overflow tank or the light will come on.

Link to post
Share on other sites
  • 4 weeks later...

I have a 92 SC400 and the damn idiot light to fill up the coolant always comes on. It comes on guaranteed if i drive the car long enough to get the coolant fully flowing. The light means that you need to top off the coolant however my coolant is completly full and does not need any more. I have checked several times and it is always full. Any ideas on this? Bad sensor? Problem in coolant system?

I had the same problem with my 94 SC400 a couple of years ago. Replace the sensor and move on with your life.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...