Sign in to follow this  
popaige

Fuel Pump Ecu

Recommended Posts

I had bought my 93 sc300 and discovered that my fuel pump ecu had been by passed.

I purchased a new one and had installed as I did not want to run the fuel pump at the high speed mode 100% of the time.

This was fine for about 1000 miles and it went out again. So I by passed it and got one at the junk yard and installed it.

I'll be dipped, this one went bad also. Any theory's on this problem. Maybe the fuel pump is shorting out the ecu??

Any advise is welcome.

Share this post


Link to post
Share on other sites

Have you looked at the wiring for the fuel pump? If they bypassed the ECU, I'm sure there's a reason. Maybe they cobbled the wiring for the fuel pump, before they tried bypassing the ECU. The Fuel Pump is a breeze to get to, and might be worth checking into.

Share this post


Link to post
Share on other sites
Have you looked at the wiring for the fuel pump?  If they bypassed the ECU, I'm sure there's a reason.  Maybe they cobbled the wiring for the fuel pump, before they tried bypassing the ECU.  The Fuel Pump is a breeze to get to, and might be worth checking into.

Thanks, I have the schematic and will take a look at it. If you can think of anything else all is welcome.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this