Do Not Sell My Personal Information Jump to content

Climate Control Blower Suddenly Goes To Low


 Share

Recommended Posts

Sorry will move this to the LS section

94 LS 400 128k miles that I bought 9 years ago with 35kmiles. It has developed the black time/temp panel and both dash issues and are at the point where I will address them. However, last winter it developed a problem with the climate control blower suddendly going to the low sped despite what buttons are pushed or where the temp is set. Then after coming to a stop the fan will sometimes go to the appropriate speed only to drop down to the low speed again when the gas is stepped on (mainly during acceleration but sometimes reving while stopped). This only happens when it is cold enough for the heat to be on not when it is hot and the AC is needed and cold air is being dispensed.. For example no problems last summer but as soon as it cot cold this winter it started doing it again.

Planning on replacing the LCD but don't want to do this if if this is an indication of the unit itself going bad.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership