Do Not Sell My Personal Information Jump to content

Rx300 Will Not Stay Running?


Jeffchs32
 Share

Recommended Posts

I have a 99 RX300 and today my car quit running. Now when i start it i have to rev it up and keep it over 1000 rpms to keep it running....if it falls below this it will die everytime. I am having it towed to the place i bought it at tomorrow. Luckily i purchased a 4 year unlimited mile warranty with it so it will be covered.

Link to comment
Share on other sites

I have a 99 RX300 and today my car quit running. Now when i start it i have to rev it up and keep it over 1000 rpms to keep it running....if it falls below this it will die everytime. I am having it towed to the place i bought it at tomorrow. Luckily i purchased a 4 year  unlimited mile warranty with it so it will be covered.

It's the idle air control valve (iacv), a common problem on the RX. It usually gets replaced but I have read posts from others who have had success just cleaning the carbon off it.

Link to comment
Share on other sites

Well they had my car all day and they cant figure out what is wrong with it. I told them what you all said it was and they were checking it. They were confused because there was no check engine light or anything came on it just quit running. They think it might be the gas. Hopefully it will be ready tomorrow. THanks for your help guys

Link to comment
Share on other sites

i wouldn;t get it service their again then if they have a hard time figuring it out.

it doesn;t ever set of a cel unless itis pluggin the egr also or foulign the o2 sensor as well.

if you aren;t paying for it get a new iacv assembly and don;t mention it needs cleaning

Link to comment
Share on other sites


Well the final verdict was the gas. They cleaned out the whole fuel system - injectors, etc. and some other things and in the end , it seems that i bougt some very bad gas that caused this whole problem...sux

Just curious, being that they spent time on the car and did clean and number of items, did they charge you because it was a customer caused problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership