Do Not Sell My Personal Information Jump to content

Ls 400 Timing Belt


philemon
 Share

Recommended Posts

I attempted toi take off my timning belt. I got all the way toi the crankbolt and I could not get it off. I used an impact wrench, but it wasn;t sucessful. I put everything back in oreder and now the card deosnt run correctly. It misses and will not accelerate. What could be the problem. I am taiking the car to the shop on Monday monring to have the belt replaced. Thanks for your help.

philemon

97 Lesxus LS 400

Link to comment
Share on other sites

I attempted toi take off my timning belt. I got all the way toi the crankbolt and I could not get it off. I used an impact wrench, but it wasn;t sucessful. I put everything back in oreder and now the card deosnt run correctly. It misses and will not accelerate. What could be the problem. I am taiking the car to the shop on Monday monring to have the belt replaced.  Thanks for your help.

philemon

97 Lesxus LS 400

looks like u missed timing when you were putting it back together

check this document that i put together when i was changing mine

http://lextreme.com/timing.htm

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership