95LS400Bob

95/96 Ls400 Low Idle, Engine Dies And Jerking Thre

Recommended Posts

2 hours ago, Andre perez said:

Whats up guys loooks like this forum is gonna save my life . I have a question though i was reading the forum and it said the ecu i want for a 1996 is 89661-50303 and the original one is 89661-50302. My ecu that i have is the 89661-50303.  Does that mean someone has replaced my ecu before ? 

I would think so.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, Andre perez said:

Whats up guys loooks like this forum is gonna save my life . I have a question though i was reading the forum and it said the ecu i want for a 1996 is 89661-50303 and the original one is 89661-50302. My ecu that i have is the 89661-50303.  Does that mean someone has replaced my ecu before ? 

 

https://parts.lexusofroseville.com/p/Lexus__/COMPUTER---ENGINE-CONTROL/63612676/8966150303.html

P/N 89661-50303 superceeds P/N's 8966150300; 8966150302; 8966150304

Your ECU may have been replaced.  It depends on production date of your chassis and the date that the supercession of the part occurred.  IOW, your chassis may have been in-process on the production line with the 50302 when the 50303 was put into production.  Odds are that it was replaced at some point after production.  I got the old service records from the local Lexus dealer for my car when I bought it used from Carmax in 2008.  These records may some of your questions.

Regardless, the ECU you want is the latest part number.  It will have the most recent calibrations.

  • Like 1

Share this post


Link to post
Share on other sites

Got it thanks! I actually went ahead and prdered the latest version wich is the 303 and installed it this last saturday. The problem i was haveing is that not often but it was starting to. Want to die at a stop here and there but just a rev on the engine and a couple miles down and it would go away. Before this happened it spent 3 weeks parked because the ecu wasnt getting any readings so it wouldnt turn on short story finally turned on didnt have any issues until this started happened. So i replaced the ecu got a new one lifetime warrenty. And now the only issue i seem to be having is that when i come to a stop and i turn and mess with the steering wheel y rpm goes to 400 -450 and wheninout it back it usually stays on that level but doesnt die onparkmyidle goes upto about 600-650 rpms and on drive it idle at strait 600 rpms no issues of it wanting to turn off so far but my idle does go down when i come to a stop and mess with the wheel for some reason. any thoughts on what could it be? I have searched on these forrems and it seems to be something with the power steering idle up valve im guess the lile black piece on the bottom of the power steering may be not working correctly ? I have changed the idle air control valve before and also i have a new maff also my throttle body is sqeaky clean. What i also found out is my old computer did have a lil burnt out spot on it so i guess maybe that was the reason for wanting to turn off before here and there and giving me low idle now it just want to give low idle when come to a stop and mess with the wheel. 

Share this post


Link to post
Share on other sites

Thanks by the way for the info on the ecu big help i was making sure i was buying the correct and up to date ecu 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...