Jump to content

OBD2 Connection


Recommended Posts

Recently aquired a 97 LS 400 With 96K on the clock. The car had a miss. I installed my Blue Driver bluetooth code reader, and it worked perfectly. Showed #3 cylinder miss. I found a cut in the plugwire, siliconed and taped to repair and the miss is gone and there were no codes.  So I do know that the Code reader will work on this car.

Now fast forward... I drove the car to my paint guy to have the rear bumper refinished. It was a trip of about 65 miles. Car ran perfect at 75MPH! About a mile from the shop the car started acting like someone was turning the key on and off. When is would cut off the CEL would start flashing.  Well after I got there. We went to move the car and it crank, but no start. I put the code reader on it, would not connect. Called Blue driver, they gave me a different sequence to connect the code reader.... still no connection. 

So I called my mechanic he came over with his Tech II computer. And it would not connect. The OBD port does have power as the blue light on my blue driver will illuminate when plugged in. So what's the answer? ECM failure? Appreciate any help. Thank you.

Link to comment
Share on other sites

Thank you, but the port does have power, and plug is in excellent condition. This only started when the car started acting up. I do not get a not connected message. I get an unable to communicate message


Link to comment
Share on other sites

Have you tried plugging and unplugging the connectors multiple times? Sometimes corrosion can prevent communication.

Link to comment
Share on other sites

Typically, a flashing CEL means that engine damage is eminent (usually catalytic converter damage).  In your case, probably due to overly rich mixture or misfires.  Perhaps the plug wire repair was temporary?

As far as no communication with a scan tool, read here.  Not saying this is the problem but it should be towards the top of the "should be considered" list:


Of particular interest from link:


This issue affects all Lexus & Toyota models with the following engines: 1JZ, 2JZ, 1KZ, 1UZ, 5E, 1G, 3S

The following are some of the models affected:

● Lexus LS400 - 1990-2000 (in 1997 and earlier models, the problem is extremely common)
● Lexus SC300 - 1993-2000
● Lexus SC400 - 1992-2000
● Lexus GS300 - 1993-1996

● Toyota Celica GT - 1985 -1998
● Toyota Supra Mark III (JDM) - 1986-1993
● Toyota Supra GT - 1995-1997
● Toyota Supra Mark IV - 1993-2002
● Toyota Supra Twin Turbo - 1993-2002
● Toyota MR2 - 1990-1999
● Toyota Camry - 1987-2001
● Toyota Soarer - 1992-2000
● Toyota Aristo - 1993-1996
● Toyota Celsior - 1990-2000


Please understand that any one of these symptoms can be a sign of ECU capacitors beginning to fail. - You do not need all or most of them to have this issue!

Your ECU capacitors are strongly suspected if you have at least one of the following intermittent issues on your Lexus or Toyota:

● problems in getting into diagnostic mode or scanner says "no communication"
● random dropping into "limp home" mode
● weird shifting problems
OBD port is unresponsive, seems dead
● throwing random fault codes
● engine won't rev out/rev limits at 2000 or less rpm
● engine runs like crap, then suddenly runs fine again
● random not starting or cutting out
● low idle or erratic idle
● often very hard to start, requires starting fluid
transmission will not automatically shift, only manual shift is possible
● transmission jerks from 1st to 2nd gear, and kinda slips from 2nd to 3rd
● no A/C compressor operation
idle speed rolling up and down, or sometimes too low and sometimes too high
● speedometer not working reliably
● speed (cruise) control not working
● tachometer not working sometimes
● air bag light flickering intermittently
● A/C going into reset with flashing front defog light (front defog light typically flashing 10 times)
● check engine light on sometimes, but no codes stored, often in concert with ECT light
ECU not communicating with scanners or not displaying codes with jumper installed
● bad sulfur exhaust smell in concert with not running right above

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Do you happen to have heavy key chain attached to your ignition key? (Is the key snug in ignition?) 

Triple check battery and terminals/wires. 

I've experienced both those. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...