Do Not Sell My Personal Information Jump to content

Seat Heaters Dead?


Recommended Posts

I bought a 97 ES300 a few weeks ago and tried the seat heaters. they don't heat at all. The illumination works on the switch. Also, when the switch is turned on, the orange indicator turns on the switch to let me know they are on. I checked under the seats. There are 2 connectors with 2 wires each. One of the 2 pin connectors has power to one of the pins no matter which position the heated seat switch is in so I assume that is for some other feature. The other 2 pin connector is dead. No power to it at all even with the switch turned on. No power to either lead. I checked the fuse and it is ok. No blown at all. Is there a relay? The engine rpm remains constant when the switch is turned on so I assume it is not drawing any load any where when switched on. What else can I check? Both drivers and passangers seat do the same thing. Everything else works perfectly in the car. I was wondering if the climate control has anything to do with it?

Link to post
Share on other sites

Disconnect the connectors and check with an ohmmeter to see if there is any resistance to the seat heaters. If you get a zero reading on the meter it means the heating element(s) are defective.

Link to post
Share on other sites
  • 6 months later...
hi, new to the forum thanks for having a place to read! My97 es300 has all options and the only thing wrong is the drivers side heated seat. Question  is there a relay that could be out? or is it the element in this seat?  any advice would be helpful  ty

Read my previous post! :whistles:

Link to post
Share on other sites

I noticed the same problem with my seat heaters but never checked the resistance at the connection points under the seat. I did take the switches out of the console and noticed that there are 2 adjustments (pots) on the switch. What are these adjustments for? Do they increase the heat level to the seats?

Link to post
Share on other sites

I have a problem with my driver's side heater, too. My problem is that the seat gets too hot...it will not turn down the heat like it used to. It is literally gets hot enough to burn. Just the element under my left butt cheek does this. Any ideas/suggestions what could be wrong?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...