Jump to content


Engine Mount / Y Pipe


nomad1
 Share

Recommended Posts

I recently went to the dealer (Lindsay Lexus) for my state inspection here in Virginia. They told me the Y-pipe ( I may have the exact term wrong here) was cracked and that it had to be replaced. They also said that two of the engine mounts were worn out and they "recommended" replacing them sooner rather than later. Nearly $1000 later, I had new mounts and a new pipe, none of which seemed to make one bit of difference on the drive home.

I bought this used from the Lexus dealer under the certified pre-owned program. Has anyone else had issues with their motor mounts? Mine has about 58k miles on it. Isn't likely that worn mounts would lead to the Y-pipe failure?

Thanks in advance for any advice.

Link to comment
Share on other sites

ok first thing is you didn't state the year or when you bought the vehicle

the y pipe will break if the mounts go as the engine will rock back and forth causeing the flex joints to open up

if you didn't hear any noise then you could have left it well alone

other thought is doesn''t the vehicle have warranty anymore?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership