Jump to content

Suspension


patruga
 Share

Recommended Posts

Folks, need your thoughts! My 94 LS400 seems to give a bit of a jittery ride once I hit 70 (and that is fairly precise). It feels almost as if the suspensions have stiffened up causing the tires to bounce a bit. Nothing is loose (had it checked) and the ride is perfect below 70. At 80 plus, it just feels like a stiff ride, which is ok.

Now for the good part! I think I have the EXPENSIVE suspension because I do not have the ride control switch on the console or in the trunk.

This jittery ride at 70, is this typical? If no, any thoughts on what may be wrong? Think the judge would be sympathetic, if I told him I was doing 100 to steady the ride? :( .

Link to comment
Share on other sites

Your car is the base suspension. The air suspension is the car with the switch. This is a good thing though because the air struts are prone to failure, and they are thousands of dollars to repair.

Have you had the wheels balanced and what kind of tires are you running and at what PSI? The LS is extremely bitchy about the wheels, they have to be PERFECTLY balanced and the tires have to be high quality and aired just right otherwise you get vibrations.

Link to comment
Share on other sites

Steve, thanks for the input. I am sure glad that I have the base suspension. I keep my tire pressure at 32psi, haven't balanced the

wheels in some time, so I think I will have that done. The tire just says Premium (No other make info), spec: 215 X 60 X 16. I was told that the tires were dealer installed...took it with a grain of salt.

Link to comment
Share on other sites

I have a 91 LS 400 with 150,000+ miles and want to replace all four struts and springs with ones made to 94 specs. The 94 has a stiffer ride than the 90-92. Does anyone know where I can get a set either low milage used or aftermarket new?

Link to comment
Share on other sites

Steve, thanks for the input. I am sure glad that I have the base suspension. I keep my tire pressure at 32psi, haven't balanced the

wheels in some time, so I think I will have that done. The tire just says Premium (No other make info), spec: 215 X 60 X 16. I was told that the tires were dealer installed...took it with a grain of salt.

They're cheap gas station tires, replace em.

Link to comment
Share on other sites

Folks, need your thoughts! My 94 LS400 seems to give a bit of a jittery ride once I hit 70 (and that is fairly precise). It feels almost as if the suspensions have stiffened up causing the tires to bounce a bit. Nothing is loose (had it checked) and the ride is perfect below 70. At 80 plus, it just feels like a stiff ride, which is ok.

Now for the good part! I think I have the EXPENSIVE suspension because I do not have the ride control switch on the console or in the trunk.

This jittery ride at 70, is this typical? If no, any thoughts on what may be wrong? Think the judge would be sympathetic, if I told him I was doing 100 to steady the ride? :( .

You may want to just upgrade your suspention. I am about 80% sure that TEIN offers a system for your car. They do have a US office. You can contact them at 562-633-7387. Give'em a call may be they could help you out.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership