Jump to content


High Pitch Whinning


magalicano
 Share

Recommended Posts

This forum is great. In addition to my other problems, a more important problem my be developing. I have noticed a high pitched whinning coming from the engine. I'm thinking it is the power steering pump going bad because it is getting harder to steer. The whinning is constant, not just when the car is turning. Any help will be appreciated. 1992 LS400

Thx.

Link to comment
Share on other sites


rev the engine slightly and turn the steering wheel

if the noise changes with steering input your pump could be failing.

common on older ls`s for pumps,racks and idler up valves to leak causing low power steering level,which makes the pump noisy.add dexron atf if it is low.

If you end up replacing the pump it is also important to clean a small screen in the steering rack at the end of the electric solenoid.a plugged screen will restrict flow and cause your new pump to be noisy.also dont put off replacing or resealing(kit) a leaking pump.the fluid goes right into your alternator.if you think replacing the pump is bad, wait til you have to replace the pump and the alternator

Link to comment
Share on other sites

Had a mechanic check the PS pumb. He said the PS pressure line/hose was breaking apart inside and causing rubber particles to fall into the pump. Drained the PS fluid and showed me the black particles. He also said my steering gear assembly needs to be replaced or a quick fix would be to add some sealant. My question: Should I purchase a rebuilt PS pump? Also, this guy is telling me that the PS pressure hose is only available through Lexus and cost approx. $320. Does that sound right?

Thx.

Link to comment
Share on other sites

I too have a 92 LS 400 with almost 84,000 miles, my power steering pump went out also, mine started with the whinning sound and then I began noticing power steering fluid leaking. I replaced mine with a rebuilt one and so far no problems. Have you gotten yours repaired yet and did that stop the whinning sound?

I still have a slight whinning sound that increases when I turn on the ac so I don't if the ac is the problem or not. The ac is putting out cold air.

Pat in Virginia :unsure:

Link to comment
Share on other sites

I have not replaced P/S pump yet. Ordered parts from Internet. Soon as they arrive, I will have a good mechanic install. I was also told that I have to replace the P/S pressure hose because this is what is broke apart and destroyed my pump. I have also noticed a leak coming from my steering rack. That will be next.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership