AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.

Stephen Alexander

ES300 Replacement Ignition Key

Recommended Posts

I have lost the electronic core of my ES300 ignition key and now only have one valet key to operate the vehicle, which works well enough. My dealer has qouted a price of $2400 to get me one functioning electronic key. Is there a cheaper alternative?


Share this post

Link to post
Share on other sites

Suggest you go to a locksmith that handles cars.  I had same issue on a Toyota Solara and was able to get two keys with electronics programmed and cut for under $200

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Hoffy5
      Happy Holidays!
      Here is my problem, my remote master keys, both of them will not lock my SC430.  If I reprogram remote buttons, the car will remotely then open and close as it should.  However then for some reason the car will go back to not receiving signal from remotes to lock or unlock car?  Also when this does happen, my Dome light will stay on, then I have to fiddle with the Key manually to have the Dome Light cycle off.
      What have I done:
      1-Replaced both Driver and Passenger Door Actuators-By Lexus Dealer
      2-Replace all new batteries in Key/Remotes'
      3-My main Car battery test's excellent, I doubt that is the culprit.
      4-I have programed my remote keys to the car so they activate remotes, that works then later fails after a random amount of says.
      ***Is there a Module that could be bad, if so, what module?
      Appreciate any help!
    • By CelesteBlanca10
      Hello. I have a GX470 2007, bought it used and it had 2 headrest dvd's already in place. We lost the remote and bought a new generic one, but I can't find the dvd player code for it to program the remote.
      I have the DVD manual, but not only it doesn't say anything about it, it doesn't even mention who the manufacturer is .. not a single link or company name of phone # - nothing.
      All it says on the manual is: "REV2 Headrest Video Monitor with Built-in DVD"
      Does anyone know the code for this thing? Or how to get this remote to work?
    • By Sensei Nacho
      For the past few months, my keyless entry has not been working. Today I decided to fix this. I followed the guide seen here, 
      . Everything works until the part where you are supposed to hold the lock on the keyfob to lock it, and unlock to unlock it. It simply doesn't do it. Does anyone have a solution?
    • By nlt999
      2007 Lexus RX350 - Trying to register new keys using techstream. Everything goes normally until the actual registration step.. says it is registering and timer starts the countdown, then after several seconds it stops with message:
      "Key Registration has failed. The communication error occurred between the key and the ECU".

      DTCs logged are B2794: Unmatched Encryption Code B2795: Unmatched key Code B2798: Communication Malfunction No.2

      Tried it using two new keys.... same failure message.

      I WAS able to successfully program the remote-entry buttons on those same two keys using the Techstream.

      Anyone have any knowledge/ideas about this please??
      Thank you! Nick
    • By Moe47
      Hey guys! Been a solid 45.5 days since the LS gave me a problem. 😅 
      Had the car dropped off at a service station for a wash yesterday, drove it around all day after it was back, even went out to get groceries late at night. Tried starting her up this afternoon, but she won't. I hear the click but no cranking after. Opened the hood to have a look and it looked like it was washed inside. Called the service guy up and he said they pressure washed under the hood. How should I proceed from here?
      Funny how the LS always surprises me with these problems. This noon, I had to get somewhere in a REAL hurry and boom! Unfortunately I didn't have my second car with me too, had to take a cab, and the cabs here are DIRTY 😰. I think It's got a mind of its own and loves putting me in desperate situations. 
      Edit: Battery is only a few months old. Headlights, radio and everything electrical seems to work fine.