AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




fsuguy

Which fuel pump is correct for 1992 LS400?

Recommended Posts

OK all you smarties, here is question that has me baffled - when replacing the fuel pump on these first gen LS400s, there are two options listed

1. The Denso, and

2. The Aisan (guatamala)

Does anyone know what the difference is, and why?  I was replacing the FP in my 1992, and not knowing any better, got the Denso from an online supplier based on their claim that it was an exact match replacement for the factory installed FP.  When I got the existing FP out, however, the construction was all metal and much more robust, with a couple of shiny bands at the base.  I did not see any branding marks on it, but noted that the Denso I replaced it with had the fuel feed nipple made of plastic, and generally appeared to be of cheaper quality (cost about $200)  Anyway, I compared prices for both the Denso and Aisan from the Lexus dealership and the prices are very different - $250 for the Denso and $360 for the Aisan (Guatamala)!!!

Can anyone on here shed any light as to why this is so?  By the way, I think that I should have got the Aisan for my LS, just based on the pictures from the dealership website show the both side by side, and comparing that to the FP I took out of my tank! $360!!!

Thanks for any insight

p.s.  For those who are wondering about the Denso - it appears to be working well, but I am concerned about its longevity, simply because of the apparent cheapness in construction.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By conforte
      Looking for anyone to comment or who has experience with this and would like to make any suggestions.


      Approximately, 350 miles from home, the steel fuel line on my 99 LX470
      rotted through and let go... The first indication was he stench of
      gasoline from the drivers seat... and then the rain of fuel in front of
      the rear tire when I stepped out to check.... I dumped 13 gallons in 6
      minutes racing to a service station on a Sunday morning at 8:00 am. Any
      one with a match or lighter could have sent a wave of flames chasing me
      3 miles into town.


      Has anyone had experience with this, who has successfully changed their fuel (and return) lines?


      I had a "bypass" installed to get me limping home.. but now the truck sits in the driveway waiting for some much due attention.



      Thanks,
      Rob
    • By Wallybally
      Hi guys,
      Does anybody know when to replace the fuel pump resistor on my 1991 LS400 ?
      All data I can find, including the numbering on the thing itself says that it has to be 0,73 ohm, and when i measure it with my digital multimeter, the value is 1,9 - 2,0 ohm.
      Seems to me that when the secondary fuel pump relay (the yellow one, just above the resistor) switches to it, the fuel pump will be slower than spec.
      Should I replace it or just completely bypass it ?
      Thanks.
      Wally
    • By agiles212
      I recently replaced the blower motor in my 1992 LS400 with a after market part, the install was clean with all connectors and fuses reattached. When I went to start the car the blower began to work however, the car would not turn over as if the fuel pump was turned off. I did not disconnect the battery before doing the install. After several attempts of starting the car I disconnected the battery cables for approximately 1hour hoping that it would reset the computer, well that didn't work either. I checked all the fuses and there were none blown. Prior to fixing the blower there were no problems with the car starting at all. There is fuel in the car, and when I turn the ignition I can hear the clicks from the FP relay, but cant get no action........Need Help....Any suggestions?
    • By finespunflesh
      I have a 90 LS400 with 190k and it was running great until...
      I was out running errands and it lurched up 200-300 rpm's and back down below 200-300 rpm's until it seemed like it was running out of gas and would almost die for approximately 4 seconds, the accelerator pedal wasn't really responding much, and then it would rev back up and limp my car ahead a bit more and then decelerate again for approximately 4 seconds and then rev back up for a couple blocks until it died a few times, I'd turn the car off, restart it, and eventually got it home.
      When I got it home I let it idle and it was revving itself up to 1000 rpms and then would drop suddenly, without me doing a thing, over and over until it eventually died out.
      So I replaced the fuel filter as I had a hard time going uphill the day before and I thought it might help, and it worked fine to the store and back. I had hoped that was all it needed, even though I replaced the filter and pump a year ago. Well today I took it out to the pharmacy and before I even got there it started doing the deceleration pattern again until it died and I eventually got it home, it dying sooner and sooner every time I restarted my car to just get it parked at home.
      I disconnected my battery for about half an hour and reconnected it. Now my car won't even start. It really sounds like it wants to and had no issue restarting throughout this entire problem, but it won't actually stay running at all now. This is identical to what happened last fall when the fuel pump went out.
      Is it common for a fuel pump to need replacement every year? I didn't think so, but what could be causing that to happen? The relay clicks and appears to be working and the engine and transmission are really great for a car that's as old as I am...
    • By ctw
      Hi, I'm a new member and a Lexus owner for 16 years. A recent incident compelled me to post here and to get some advices.
      Currently I drive a 2006 GS300. All maintenance services and repairs were done at the dealer. Ten days ago, I drove out of the parking lot and noticed the "check engine" light was on. I pulled of to the roadside, turned off the engine and tried to re-start, but did not succeed. I called AAA and the car was towed to the nearest auto shop. My friend came to pick me up. He tried to start the car. This time it actually got started. I decided to drive straight to the Lexus dealer.
      After the Lexus technician inspected the car, they said the Fuel Pressure Sensor needed to be replaced. The cost was about $830. After they replaced it, they discovered that the Fuel Pump and Spark Plugs were damaged. The total cost would amount to about $2500. I told them that I would have the car towed to a local mechanic to fix the fuel pump at a lower price. Next day, the dealer wanted to keep me there and offered to fix the fuel pump for free. However, they found another problem with the fuel gauge. They also offered to replace the fuel gauge at no cost. I agreed to let them complete the repair but requested to keep the old parts for me to take away. They had no problem with my request.
      Three days later, the service consultant told me that I could not have the old parts back because the dealer repaired the car under "Gooldwill Warranty" so the old parts had to be returned to the manufacturer. At this point, I was so confused and aggravated that every phone call there was something new came up. I asked him to explain the whole process in writing and email to me. He would not do it but said a manager would contact me the next day.
      Any comment on my experience?
      Could Fuel Pressure Sensor, Fuel Pump, Spark Plugs, and Fuel Gauge all broke at the same time?