AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoticons maximum are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By ez12a
      Hey All,
      Just wanted to share some video DIYs i created when I did the 120k mile service on my GS350. 
      Here's how to replace spark plugs:
       
    • By AKAP
      Anyone with an LFA on the east coast want to do an LFA only meetup / drive event?
    • By Andy_N
      Hi Guys,
      Couple weeks ago, my Lexus hybrid system light came on. I took the car to a  local Lexus dealer. They charged me $160 just to test the engine light and  told me to replaced my hybrid battery for $6,700. I am so broke I declined the replacement.  Last week, I opened the hybrid battery and tested all cells. Turns out all cells are fine. I reassembled the battery back in place and drove it for another week. Today while driving 70 mph on the highway the "warning hybrid light" comes on again  including check VSC, check ECB. Does anyone here has the same problem like it do? I know the battery is fine. Could the battery converter causing this problem?
      Any advise would be appreciated.
      Thank you.


    • By datarecovery
      This is a new car to me that I bought with the no start engine. Only 42000 miles since last timing belt change . Here's what I found when I opened it up.
      Several bolts on water pump  housing were loose. Alternator lower bolt was broken. The tensioner pulley was completely  broken apart so I don't have any pictures of that . Water pump shaft was bent and water composed inoperative. That's why the coloring on the water pump pulley is shows discoloring from the Heat. Who knows what happened in terms of the sequence....
      Anyone ever see this on a Lexus? I've had 10 Lexus before, worked as a mechanic 30 years, and I've never seen this before.