Jump to content

  •  

Photo

Check Eng Light On ,check Vsc And Traction Light On

Transmition problem

  • Please log in to reply
4 replies to this topic

#1 GSLike

GSLike

    New Club Member

  • Members
  • Pip
  • 1 posts
  • First Name:Man
  • Model: Gs 300
  • Year: 2006
  • Location: Other

Posted 05 April 2012 - 02:18 PM

I Bought a used 2006 GS300 about 1 months ago. After about 1 week the check engine light came on plus Check VSC message and traction light as will and the transmition shifting is not smooth i Took it to the Lexus dealer, and they said that i have to change the solonid and the bodyvalve of the transmition gear and this is too costly can any body advise?

Have something to contribute?

Sign in or register to start a topic...

 

#2 abriel

abriel

    New Club Member

  • Regular Member
  • Pip
  • 6 posts
  • First Name:Gabriel
  • Model: ls430
  • Year: 2001
  • Location: Alabama (AL)

Posted 09 April 2012 - 04:20 AM

I Bought a used 2006 GS300 about 1 months ago. After about 1 week the check engine light came on plus Check VSC message and traction light as will and the transmition shifting is not smooth i Took it to the Lexus dealer, and they said that i have to change the solonid and the bodyvalve of the transmition gear and this is too costly can any body advise?


it may be a bad parking brake switch, low level of brake fluid or a bad brake light switch.

#3 Dave Shaver

Dave Shaver

    New Club Member

  • Regular Member
  • Pip
  • 3 posts
  • Model: 300h
  • Year: 2013
  • Location: Texas (TX)

Posted 15 April 2012 - 08:15 AM

As stupid as it sounds, try tightening or replacing your gas cap. If the cap is leaking, your car may go into "protection mode". I had my Toyota Van (2011 Sienna) do this exact thing; the check engine and traction control lights came on. Fixed by tightening gas cap.

#4 Carlos A Gomez Rosa

Carlos A Gomez Rosa

    New Club Member

  • Members via FB
  • Pip
  • 1 posts
  • Location: Please Select

Posted 20 April 2012 - 04:11 PM

Tightening the cap fixed it for me. 2004 LS 430.

#5 boB_2006_GS300

boB_2006_GS300

    Advanced Club Member

  • Regular Member
  • PipPipPip
  • 103 posts
  • Model: 2006 GS300
  • Location: Please Select

Posted 20 April 2012 - 05:51 PM

make sure you have a good battery as the transmission shifts electronically. also make sure all of your fuses are good.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have