AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




SKperformance

Tells Us About Your Car And Its Mods Or Problems

Recommended Posts

My 1992 lexus sc300 115k miles when idleing has a chopping sound onnly for less than the minute but it sounds like the fan or the belt right by the fan rubbing against something maybe? Please help

Share this post


Link to post
Share on other sites
 

i have a 93 sc3oo jus replaced the head and head gsket drove it one day and spun a rod bearing selling the car if anyone wants to offer me a price i would be glad to send pictures text at 478-365-5599i have a good bit of money in the car so i cant sell it no less than 3500!!!!

Share this post


Link to post
Share on other sites

92 Lexus SC300

Brought it with 202XXXk miles Rare 5 spd manual $1300

Car was in decent shape drove it back from colorado springs to denver about a hour and a half drive ,no problems.

Mods-

Kyb struts/shocks

intrax 1.5" lowering springs

Aftermarket HID kit

Kenwood head Unit

Pioneer 4' speakers

18x8 is250 ISP wheels

Maintenance-

oil change

iridiums spark plugs

tranny fluid

intake filter

Problems when brought-

Interior pretty torn up

transmission grinds a little

paint fade

alignment

blown front shocks

gauge needles out

climate control

Share this post


Link to post
Share on other sites

Hey guys,

So I joined this forum a few years ago and was really determined to do some work on my 93sc4 but unfortunately I never got the time too. However, finally the time has come!

So far Ive added:

- Custom made Short ram w/ 3inch cone

-18in ROTA Subzero rims 225/45/18

in the next few weeks im adding

-Supra lower control arms

-Meagan or Blitz Nur Spec cats

Now my question was related to suspension. I'm having a hard time deciding between shocks and struts or just doing a coil over kit. Theres about 1.5-1.75in of space from the fender to the tire and i want it sit pretty snug. In addition to that wheel spacers were also a thought while suspension work was in the mix. Long term project will be to add some long tube headers, supra fuel injectors and pulleys and do some cosmetic repair to the paint. Maybe even paint the rims with a time attack strip

If you guys had any advice for me on some good parts or brands to look into thatd be awesome!

Thanks

post-91433-0-61523000-1350365889_thumb.j

post-91433-0-67948600-1350365897_thumb.j

Share this post


Link to post
Share on other sites

Bought my 1992 SC400 with 133K original miles for 2048 bucks from a close friend. It needed a few things like brakes, tires, ac charged, and an alignment. All was good till the service come along. Ended up hanging on to this car due to the look, feel, and driveability of it with hardly any problems. JOined another forum, did a complete motor swap, and the rest is history. Everything has either been upgraded or repalced at one time or another. Have maybe 30K in it presently... Here is sits at the last car show..

i-25FmbP6-M_zps85158c58.jpg

LexusSC_zpscb33e136.jpg

i-kgj7ss7-M_zps60743f27.jpg

1006120933.jpg

Share this post


Link to post
Share on other sites

Here are my mods

Wet 100 Shot of NOS,Front LS400 BBK Calipers painted gold,Goodridge stainless steel braided brake lines,Blacken Emblems,Polished Intake,Tanabe Springs,8k Hid's 6k fogs,Tranny cooler w/fan,EXE Konvex Front 19x8.5,Rear 19x9.5.

14.1@96pmh on NOS

NA-T(Under Contruction)4" intake,Borg Warner S300 83-75,Nos,Stainless steel manifold,Tial 38mm WG,2 Blitz BOV,Aeromotive FPR,850cc,Twin in tank Walbro fuel pump,AEM standalone,Aem Wideband,HKS Cam Gear,Blitz SBC i-D Boost Controller

Share this post


Link to post
Share on other sites

1992 Lexus SC400

Parents bought it for 3000 at an auction

Everything works perfectly except when I put in a cassette to plug my phone to play music, the sound quality sounds a bit crackly. When I use the radio, the sound is perfect. What do u think is wrong?

Share this post


Link to post
Share on other sites

bought 93 sc400 6 years ago, now I just bought a 95 sc400 6months ago, twice as much fun, paid 7,000 for the 93, just paid 7500 for the 95, it has 95,000 miles on it, the 93 is black, the 95 is silver blue pearl . second owner cars, 95 completely stock, my wife loves it, the 93 has been put to the test, headers, new exhaust from the headers back to flow masters, nothing else, last summer I has a 125 shot nos setup on it, and it was more fun than a ride at magic mountain, but its tough on the trans, and I got my first speeding ticket in 25 years, a week later another so I removed it, plus the gas is expensive, but you surprise a lot of people when you stand on it. really noisy. today my cel light came on and code 13 came up, started to check it out and found the coil wire and cap on r/s was burned and the rotor was also, replaced them all and will try it out in a few, had my radiator explode, plastic top of it just blew and antifreeze blew all over the engine, I think it got on the distributor cap and corroded it. had trouble with door locks, lever on handle came off, nothing to fix it not many other problems, I maintain it very well, it something I keep after, I put custom wheels on it and soft tires and kyb shocks new springs, shock tower supports and you can drive both cars and not believe they are the same car.

Share this post


Link to post
Share on other sites

1997 sc300 with 4.27 rear gear.Want to change to 3.92 gear. anyone done this? thanks terry

Share this post


Link to post
Share on other sites

1992 SC300

3 owners, all family members

I've had it for about a year and it has a problem where the tranny doesn't want to kick down from 3rd gear. It's only intermittent and i've replaced the whole tranny solenoids and all. Only thing that can be wrong is the wiring or brain. Any suggestions or anyone else experiencing this?

It has all the options but traction control (no idea if it was an actual option or not) and heated seats.

Also, it has about 165k miles on it and the engine works perfectly. Please help me out with this.

Share this post


Link to post
Share on other sites

1995 Lexus SC400

price 3775

251k currently

modified exhaust , currently no pre cats or cat due to catalytic converter explosion .

new coils ,caps ,rotors,wires,and plugs

new throttle body from a 50k mile sc400

new transmission tail housing seal and filter and pan gasket upgrade

second owner

Problems : cat blew up on freeway even after replacing both coils

throws codes 24 ,25 , 31 , & 47 . all mass air flow related and then code 47 is sub TP code .

bad driveshaft bushings

dash board lighting issue

Share this post


Link to post
Share on other sites

My name is Josh. I've owned my 1998 Lexus SC300 for three years. I'm actually the third owner, so the first two owners took care of it pretty good. I have done no mods to it. The only thing that doesn't work is the cd changer. Here are some pics when I got it in 2011 (94,700 miles) and I detailed it (clayed, polished, and sealed). It has just ticked over 111,600 miles as of today. I still looks the same three years later, just not as clean at the moment. I paid $7,800 and I get my repairs done at

http://www.craigautomarietta.com/

an independent Toyota/Lexus shop. I have had my spark plugs changed, brakes, and new engine and transmission mounts.

I would upload photos but it looks like the upload media link on the forum is giving me a 404 error. If you want to see pic check out clublexus forum for me I have the same user name and pics up on that forum.

Share this post


Link to post
Share on other sites

94 es300 165,000 miles.

paid 15k$ in 1999. replaced engine in 2003. swapped out calipers once and rebuilt them twice, since . last set i primed twice and finish painted hammered gold so as to keep them clean for next brake job. they look great and glad i did it.

replaced the power antenna. replaced the sunroof (cracked glass.)

Problem today=

need help with removing the rear power steerin bolt, cannot get at it. any clue as to best way to get it off? forward bolt came off fine. rear bolt is hidden and problematic. thanks.

Share this post


Link to post
Share on other sites

Hi everyone, my name is Ky(kee) i have a 98 SC400 got it for $4500 in '12 right at 163k. Right now it has 187k and still running strong.

i have done some cosmetic mods such as rear tail lights, HID headlights, LED foglights. future mods gona be ballistic body kits from CarID, intake/exhaust. Ive been thinking about boosting it. Things are still on drawing board right now.

Well everything been going well up until 2 wks ago when my alternator stop charging the battery. After trying to troubleshoot the alternator i notice it was soaking with some kind of fluid. Long story short it was my leaking power steering pump, PSP. So i bought the rebuild kit for it and everything went smoothly up until i reinstall the pump. I did everything to bleed air out of the system but i still dont have power steering at all. The system dont even make any sound at all when i turn and lock the steering wheel left or right. I can see the fluid being push/pull into the system from turning the wheel. But all quiet and no power steering. I hope i didnt kill my rack/pinion in the process. So if you guys have any idea please pass it along this way would be greatly appreciated.

Share this post


Link to post
Share on other sites

hey everyone! new to the forum!

1995 sc400 with 2jzge swap

bought it the other day for $2500

miles on it: have no idea

Previous owner had told me that he had rebuilt the motor from top to bottom with vvt-i internals but he sold it to me as a sc300 model. the day I left my car with the mechanic whom I've known for 14 years was the day I found out that it was a swap job and a very good one at that. it is my first lexus and also my first rwd car and am very happy with my purchase. as soon as i get the car back from my mechanic i plan to fix up the interior because it is shot! anyone can tell how i can fix the led's on my gauge cluster? I reside in Puerto Rico and thanks for letting join!

Share this post


Link to post
Share on other sites

sorry, duplicate post

post-126050-0-55243500-1406055352_thumb.

post-126050-0-65199400-1406055361_thumb.

Share this post


Link to post
Share on other sites

New here. Just bought the biggest mistake of my life, but I am taking it all as a learning experience & hope to get some fun out of it too.

1992 SC400
Previous owner swapped a 5 speed R154 transmission from an MK3 Supra, custom welded the shifter to extend to the proper location, 6 puck flywheel.
He also put in Megan 32 way adjustable coilovers, rolled the fenders & threw on some 18" with stretched tires.

So far I have had to replace the tires due to improper camber adjustment ($700), replace brake pads all around ($200), and now have a broken camber bolt that my shop is trying to fabricate a replacement for.

There are many other little things that I will have to deal with over the next few months too. I overpaid for sure, having paid $5300 CDN. But I am learning how to do alot of work myself, and it is an absolute blast to drive when it's running.

When I get the paint issues sorted out somewhat it'll be pretty decent, I just hope no other major disasters strike.

Share this post


Link to post
Share on other sites

List your model, year - 95 SC 400
# of owners - Two
price when bought and from where - 14,400 from private owner
lenght of ownership and attributed problems and repair costs. - Bought 2002; repair costs minimal till now - battery drain
Also mention where you had it fixed ( lexus, independent, midas or diy). - Two independent repair shops and Lexus Bev HIlls
When it was done.- Spanning 3 years to present
Any mods done to the car and its costs. - No
If desired your age and insurance you pay.

I am in desperate need of someone who can diagnose the reasons my battery goes dead frequently. I have been told by two auto mechanics - including Lexus - that it's from a dome light that I forget to turn off. But that doesn't wash. I hardly use the dome light and when I do, I am obsessive enough to turn it off. Can anyone suggest a skilled (and honest) Lexus auto mechanic in Los Angeles City area that I can go to to finally get to the bottom of this. I'm going nuts. And it's my only car. And I love it but it's losing favor by being a constant source of angst.

Share this post


Link to post
Share on other sites

I have a 92 sc 300 and it's blowing gas into my intake box. What could be the problem?

Share this post


Link to post
Share on other sites

95 SC400

85K original miles

Has been sitting for about a year

purchased 8/1/2014

Many refurbishing questions will arise.

In progress:

Previous owner died in middle of reupholstering. Passenger seat done.

Nice red stitching to match exterior color. Black leather.

Driver's seat kit included in sale.

rear seat back top VERY deteriorated from sun damage.

Ball park DIY on the kit for the driver's seat?

Anyone had shop do rear?

Eventual respray entire car. Not rust or body damage.

Any comments are helpful.

Will be a keep me out of the wife's way project for some time to come.

Philip

Share this post


Link to post
Share on other sites

I recently purchased a 1993 SC400 with 56,000 original miles in almost mint condition. I had a written appraisal by a state certified appraiser for not less than $12,000. It's pearl white with the tan leather interior. Loaded with options.

I was wondering if there are any performance mods available for this model or would it make more sense to find an SC300 with the inline six or maybe even swap the 8cyl. for the inline 6. The body and interior are almost like knew and although the engine, trans and rear are perfect,it is slow by todays standards.

Just wondering. It's so nice I'm not sure if I really want to adulterate it at all.

Thank you:

Gene

Share this post


Link to post
Share on other sites

Hello all new Member here

Picked up a 95 SC400 with 132k Miles

Had replace my belts and ECU. No I am looking to make some serious modifications over the summer. I was thinking on starting with the engine first then Paint and Body ( Body Kit) Exhaust then wheels and tires. Any suggestion on what I should add to the engine for more power. (Super Charger not I the budget).

Will post Pic tomorrow if the suns out..

Share this post


Link to post
Share on other sites

In 2009 Bought my 1992 SC400 Green with Tan interior fully loaded for 600 dollars because it was overheating. It was a simple leak from the thermostat joint. I felt bad for the person I bought it from. But he had LS400 in the wings. I fell in love with the Borla twin exhaust with a crossover H Pipe sound - mesmerizing. Have driven it probably 6 times to Florida roundtrip;(28MPG) one of the best cars I have ever driven (used to drive Mercedes S-Class) and sorry to have to see it go - parting it out at 225K miles.got it at 140K

Has TEIN shocks lowered so it rides on rails. The camber was factory set but the cars are known to wear on the insides front and back. That is how they are setup.

Rebulit the ECU two years ago. Needed the capacitors - the dreaded ECU probelms.

Synthetic 20-50 Mobil One.

Has been very problem free - utter reliablilty until the North East Storm in January fully loaded the engine compartment with snow - twice! Now not running so well - missing on the right bank! Replaced drivers coil runs a little better, but not perfect.Front calipers started sticking and was going to go to 17 inch wheels and 95+ front brake upgrade ..... but no more ,,,,

I got my moneys worth and hope to find another one!

Share this post


Link to post
Share on other sites

My names Chris and I just bought my sc400 about a month ago for $2,000 and 166000 miles. My CEL light is on and my "trac control off " light also comes on. My AC doesn't work and my passenger door won't open from the outside. After about a week of having it I noticed it started to bog while I was at idle. It felt fine while accelerating but once I tried keeping a steady speed it got real jerky. Check the obd codes and I had four different codes. Air/fuel lean malfunction, o2 sensors, maf sensor and I forgot the last one. I did a lot of research and found that the ecu might be the culprit to these problem, so I took it out and sure enough I noticed 3 capacitors leaked acid onto the board. I got in touch with Tanin Auto Electronix and within 2 weeks I received my ecu with the capacitors replaced. I hoped and prayed that would be the answer to my problems. I connected the ecu and nothing had changed. Same problems same CEL lights. A few days later my neighbors stopped by and helped me clean the iacv, hoping that this would help, and the idle got bad. My other neighbor brought me sea foam and the idle went back to normal. But again when I kept it at a steady speed it would bog again but not as bad. So I disconnected the maf and ram it like that and it ran fine but gas economy wasn't. So my other neighbor mentioned the pcv valve. He said he had recommended replacing it to a few people and their problems were fixed. I didn't take his word for it and I went and got a quote for new maf sensor and o2 sensors which would be about $500-$550. Since the pcv valve was only $5 I thought I'd start there. I did a little research on it and it sounded like it could possibly be the problem. So I went out and bought one and to my surprise the CEL lights came off and the idle went back to normal!!! I noticed my Cel lights come on again but it still running fine. I'm thinking I still need to replace the o2 sensors since it still has the original Denso sensors. A buddy of mine said the o2 sensors being bad could be causing the trac off light go on. So that'll be my next purchase and hopefully I won't be disappointed.

Share this post


Link to post
Share on other sites

92 sc400 mostly all stock parts

I'm new to this club and I have a problem with the car at 80 km once its reached regular temp it makes a whirring whom whoom whoom humming noise (rotating) it's only at a steady speed of 80 km goes away when I slow down and it's not present or at least I can't hear anything below 80 any ideas ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now