AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




SKperformance

Tells Us About Your Car And Its Mods Or Problems

Recommended Posts

List your model, year ,

# of owners ,

price when bought and from where

lenght of ownership and attributed problems and repair costs.

Also mention where you had it fixed ( lexus, independent, midas or diy).

When it was done.

Any mods done to the car and its costs.

If desired your age and insurance you pay.

If you have any picutes in the gallery put links in the post so we can have an idea about the car.

Please only post once and if you have a question either pm the member or make a new thread .

This will keep the page from being filled with excess.

Share this post


Link to post
Share on other sites
 

This thread in particular will be very helpful to new owners and potential ones, first here's a few things that might help;

TEN SC300/400 WEAR ITEMS

1) PS pump can go bad and can also leak fluid onto the alternator which is right below it and take that out as well.

2) Control arm bushings

3) Gauge cluster needle illumination

4) Climate control LCD display

5) Torque converter weakness

6) Window regulator

7) Headlamp fogging/yellowing

8) Heater control valve

9) CD changer skipping

10) The SC is also very sensitive to wheel+tyre balance/pressure/offset issues

as for mine...

1995 SC400

The local Lexus dealer here consists of a bunch of incompetent rip-off artists and hacks, therefore I only use them for things which are warranty-related, first time I brought it to them for something they gave me the impression they knew nothing about the car short of plugging a scan tool into the diagnostic port. They don't even change the fuel filter when a car comes in for service, because the fittings are sensitive to stripping, 125k mile LS400 comes in and they'll leave the oe filter in there. They weren't even using Dex-Cool for awhile, I tried to explain to them that the Boric acid in green coolant can create a corrosive condition in the alum head (and block in the SC4), they couldn't possibly have given less of a crap. I try to do everything myself when time allows. I've had this car for years and it has never let me down, *knocking wood* Never had a part fail but i've replace both motor and trans mounts which I felt were becoming weak. Brakes are also freaky good on this one, stops about as good as the TT brakes on my other one. Terrible in the snow, even with a load of kitty litter in the boot. As far as mods, 2K front conversion, system, alarm, rims, basic stuff...maybe eight grand in extras.

1999 SC300-T

Shortly after I bought it I sent it to the above Lexus dealer under warranty b/c it wasn't running right, I felt there was some water in the coil pack tray and told them to clean it out and install a set of plugs while they were in there. They told me the head gasket was blown, that it wasn't covered by Lexus warranty (!!), and that it would be over a grand. I told them to throw a set of plugs in and give me my whip back before I started kicking teeth in. It's so smooth you couldn't even tell it's running, and the six with the vvt-i is just about as quick as the four litre and more responsive. Jay Leno says BMW builds the best inline six, makes me wonder if he needs a 2JZ in his warehouse. Long story short, never broke anything until I turbocharged it :rolleyes: . As far as mods sk, I won't get started on that.....after the new motor i'll be into it for well over $40k and still have several things left to do, hoping to finish before I hit $50k.

2002 RX300 AWD

Aah, the dealer again! My fiancee and her father decided to do this on their own and turned down my help, regardless of my connections. Matter of fact, they didn't even take my one biggest piece of advice, don't go to the above dealer! They proceeded to walk in and choose an RX off the lot, got absolutely raped on the payment, they didn't even detail it for delivery, filthy, grease on the leather, etc.

Low and behold she takes it home and I fine-tooth it, and discover it had been hit in the back and repainted, and the crappy work was already starting to show, brand new car folks. Needless to say the dealer did nothing to make this right other than repainting the bumper cover again, didn't even bother to give an excuse, and my fiancee and her father wouldn't let me settle this NY-style, so that's it. We've had it for I guess about 18 months now, no problems whatsoever other than fixing a loose exhaust a couple days ago, drives smoother than my coupes, peppy, and is great in the white stuff. Not a single mod, she says if I put rims on it she'll curb every one of 'em :) .

So who's the dealer? Lexus of Massapequa

Share this post


Link to post
Share on other sites

1992 SC400

purchased:august 2003

priced at:$7500

mileage: 107,000

mods: BFI, AT cooler, custom grounding kit, going supercharge in dues time.

major tune-up: all fluids and filter changed, timing belt, water pump, distributor caps/rotors, plugs, plug wires, brakes, etc...performed myself for less than 400 dollars.

pros: the overall feel of the vehicle is a dream.

cons: wish it was faster, since it IS a V8, but a supercharger should fix all my complaints.

myself: 19yr-old male, 5th registered owner to the car.

  • Like 1

Share this post


Link to post
Share on other sites

1992 SC400

Purschaed with 60,000 in 1995 now has 106000

Mods Upgraded speakers, exhaust system cat back custom, borbet rims, cross drilled and slotted rotors, and one he** of an alarm ( i live in phoenix i know so many people that have had there cars jacked )

Mods in the works Working with a guy from austrilla to see if the headers of the V8 soarer will fit my US SC400, 100 shot NOS, New exhaust, RMM Valve Body upgrade, torque convertor, RMM ring and pinion set, MSD 6AL ignition, New ignition coil, and a few others, some parts i have already others i am still saving all i can say is i have about half the money aside to pay for what i dont have yet.

Problems: my dad <_< ran over a 2x4 on the highway and messed up a control arm, just had an eletrical fire that burnt up two wiring harnesses that is costing me $3000 :angry:

Share this post


Link to post
Share on other sites

'92 SC400

bought for $3750 in Feb. 2004 after my Camaro got totaled.

a few probs, radio went out completely--grounding out somewhere, guage needles, and i've already conquered every 'routine maintainence' catagory

bought in KCMO, i live in Kansas City, Missouri

Share this post


Link to post
Share on other sites

H3 sorry... 1991 Soarer 2.5TT

Purchased in December 2003 for $1800 with 85000km.

Purchased with TRD 2-way diff, 5 speed swap completed, JIC coilover suspension, Beat up front bumper, unknown sidesteps and rear unders, and no muffler

Current mods are speed and boost limiters cut on stock 5sp computer, 80mm Full stainless front pipe (2-piece, no cat) and 80mm full stainless exhaust, and drivers side Reclining bucket seat(much lighter).

Planned mods include 6pt rollbar(purchased not installed yet), Oilcooler(purchased not installed yet), New coilover suspension, replace bushings, Full Aero kit and respray car new color, Power FC computer - Boost up tune, fix blinky dash, and passenger side reclining bucket seat

Need to fix blinky dash (I envy you all with working analog guage clusters), as well as change timing belt and serpentine accessory belt.

Share this post


Link to post
Share on other sites

DRobBham Writes:

"I have a 1992 SC400 That I have had for over 5 yrs. Mileage is around

208,000. The Total Extent of my Repair issues consist of Hmmm....

Lets See... Well I Had To Replace the battery once... normal (loving)

Maintenance i.e. Brake Pads, Fluids, tires, Etc. And Absolutely NO other

Issues. Would Find it More Trustworthy on a Long trip than my Other

Vehicle. 2002 Grand Cherokee Limited.

Lexus is a GREAT vehicle! Strict Unwavering Loyalty...

Until this weekend...

Not Sure Exactly what happened... in a three day period, 1. The

Power Window Actuator went out in the Drivers window,

2. The Illumination went out on BOTH the Guage Levers on Dash. (Gas

and Temp} 3. The Tilt Steering Memory/adjustment suddenly started

making a LOUD noise if you attempt to lower it. It is STUCK in the all the

way UP and all the way OUT position.. (quite Umcomfortable to drive)

4. The "TRAC" light is suddenly ON all the time.

5. Just Noticed a NOTICEABLE Vibration in the steering. Upon

inspecting the condition of front tires, found them toi be in QUITE poor

condition. (15K Miles into 60K Tires.) Apparently Front End is suddenly out

of alignment.

Anyone have any knowledge of A cherished, Loved, WELL cared for Lexus

having a Hiccup??

More Importantly, Had the Window Actuator, replaced at the Dealership.

The Modules for the "TRAC" and Guage Leevrs are on Order. The

Alignment Will be in the Morning... But The part that has me puzzled is this.

The Service Director (great guy) Told me that he felt strongly that the

motor was fine in the Tilt mechanism. He says he has had several with

the same issue and that when they get into replacing one, they usually

always find that it is only that the Bold / fasterer has back out enuff

to allow the gears to not mesh properly. He said that it was most

likely something that i could repair myself, and that the cost of having it

done at the dealership was QUITE Offensive.

Hence, I can fine NO information, Schematics, Manual for how one would

go about getting TO the module. Whats it look like, etc. I have

started it once and realized quickly that there must be a way that i was just

Not comprehending. I am somewhat mechanically inclined. Change my own

pads, belts, etc...

Any Info about How to recognize the Module... What all needs to be

removed Cosmetically? Anyone else attempted this??"

DRobBham:

Please go through the Visitors and New Member forum for instructions on how to use this Forum.

http://us.lexusownersclub.com/forums/index.php?showforum=27&

Share this post


Link to post
Share on other sites

Just bought a 1992 SC400 w/ 159k for $5,000 through ebay. This will be my project/fun car while I drive my '00 RX300. Been pouring money into it ever since trying to get it to where I want it. Here's the list.

Problems:

Excessive road noise - replaced transmission mount and drive shaft bushings and some shifter parts

Electrical problem - dim lights and radio would shut off when brakes applied (fairly common). Replaced negative battery cable, installed new battery and a grounding kit

Gauge needles-will be sending to Lextech for new needles and backlight

leather seats-replaced w/ seats from 97 SC400 (RIP)

Oil leak - Crank seal went, had to replace timing belt (again)

trunk support struts replaced

yellowed headlights-cleaned and polished :D

Maintenance:

Oil change, transmission fluid change (Type T-IV of course), NGK Iridium plugs, wires, caps/rotors, fuel filter

Mods/upgrades:

18" HPRacing HPR5's w/ 245/45/18 tires

replaced K&N cone filter kit with BFI (definitely the way to go)

Kenwood double din CD/Tape Headunit upgrade w/ 1/2 din storage tray for filler

Brushed aluminum dash kit

More to come......Does it ever stop?!!

Share this post


Link to post
Share on other sites

sep guys, 1st post. I'm a new member to this forum and owner of a 3 week old '93 sc400 w/167,000 miles. besides the usual problematic things with the sc's mine makes an unusual sound when going over 40mph. there's like a loud rumble under the car when you accelerate and when you get off the throttle its a little louder? I'm very puzzled by this. any suggestions. don't thinks it's the tires or engine. I have full power, I guess from the 3 weeks I've had it. this just started 4 days ago and is getting noticably louder. can it be an exhaust leak? has anyone had this problem before? thanks. sorry moderators if this is not the right thread to post. I searched and found nothing.

*must note*

car is stock except for 20" rims and they have no uneven tire wear.

Share this post


Link to post
Share on other sites

I have a 1994 SC300. Bought the car about 4 months ago from a used car dealer in Orlando, Florida. Paid $5650 for it. Car had 72,000 miles when I got it (has 76,000 miles on it now). As far as I can tell I'm the third owner (Second owner was original owner' son).

Problems with the car:

Replaced the rear trunk struts with new ones for a car with a spoiler (mine has no spoiler). The trunk now opens very quickly and stays up. Probably should have gone with the weaker struts for a non-spolier equipped car.

The front driver's seat has a small rip. Was quoted $400 to recover the seat cushion. So far not fixed.

The driver's door has small dent. Body shop estimate at $400 to fix. Not fixed yet (It's not that bad).

It has an aftermarket stereo system. Plays fine and looks OK, so no changes planned.

Biggest Problem: The Check Engine light is on. Had it checked out by a Toyota Dealer (no Lexus dealer near my house). They told me the code indicated an EGR Temperture problem. They thought it was the sensor, but did not want to change it themselves as it was pretty expensive ($180 for the part). Suggested I take it to the nearest Lexus Dealer (who wants $180 for the part and $180 to install). Toyota dealer charged me nothing (that's right $0) for doing all the diagnostic work (Thanks Lighthouse Toyota in St Augustine, Florida!!). I took the sendor out and cleaned it myself. (It took me ten minutes to remove it). That solved the problem for a few hundred miles, but now it's back. Will probably buy the part and install it myself.

Does anyone know of another source for this part besides Lexus??

Other than that, only complaint I have is excessive road noise. I think that this is from the tires (Bridgestone Eagers). I'll be putting new tires on soon.

Typical maintenence performed by myself included: Oil and Filter, new fuel filter, new air filter, flushed and changed the coolant, and changed the serpentine belt.

All in all a great car. Engine runs great, absolutley no rattles, very pleased.

Share this post


Link to post
Share on other sites

Car is early 1992 SC300 with a W58 manual gearbox. Previous owner has destroyed the interior. Cracked leather and door panel splits. I have waited to find this car for a long time. Lots of restoring to do. Runs great and everything works except that the CD changer needs the updated eye. I won't say how much I paid for it :rolleyes: .

Share this post


Link to post
Share on other sites

I bought my 95 SC400 5 year ago. It belong to a family friend who give me for 20 grand. It was super cheap at that time for a car like this. It was 70K when got it and now 190K. I drive this car alot, cuz I love it like hell. I change the Timing Belt, Water Pump, Alternator, Battery, and Radiator. My friends and I work on my car. We like to do work on our car rather than take it to the shop.

Mods: 600watts Kicker Amp with 2x10" speaker in trunk. 1X10 Kicker in rear where stock base is. 2X 6 1/2" Alpine speaker rear and Infinty in Front. HKS ground kit system, Intake, JIC Strut bar, Tokico Illumina Adj. 5 Suspension.

Coming Soon Mods: DS rotor, 19" wheels, JIC magic body Kit (For Sure) or Phoenix body Kit ( If have enough cash), Dash lighting, and paint job.

Share this post


Link to post
Share on other sites

95 SC300 purchased Aug 03

90,000 miles, $10,500.00

17" IS300 wheels/ 245/45/17 Mohawk Perdators

BFI/K&N

Iridium plugs

Sylvania Silverstar headlights, high beams, fog lights, turn signals

Replaced antenna mast

Rear calipers and rotors from Supra TT. (Fronts didn't fit with new wheels )

Stainless steel brake lines

Polyurethane swaybar bushings

Everything else works except pass. side interior door handle

Share this post


Link to post
Share on other sites

:cheers: I just bought a 93 sc400, from another member here, up in boston. I just got back back from driving it down to atlanta. I must say that it has alot of power. she didnt present any problems on the way down.

the body is in ok shape. i am a bodyman, so im not too concerned with the body. in a month it will look new. but can anyone here give me some tips on the motors? how are the transmissions in these things?

Taj Turner

Share this post


Link to post
Share on other sites
Rgenender Writes:

"2002 SC430. Have less than 14K miles on it and have had it in for all

service intervals. In the last 4K miles, or so, the inner treads on both

rear tires have become bald, while the rest of each tire has

progressively more tread as you go from inner tread to outer tread. The outer

tread appears to have very little wear. After about 5K miles, a man pulled

up to me at a light and said that my rear wheels looked like they were

bowing out on the bottom.

I keep the tires at between 37 and 38 psi.

I know that the rear suspension has negative camber, but could it be so

bad as to produce this kind of wear? Lexus dealer says that they have

seen this before, but want to track it in future.

Could their alignment machine be miscalibrated? They say impossible."

RGenender:

Please visit the "For Visitors and New Users" Forum for information on how to use our Forum correctly. It's really not that hard.

Thanks

UCF3

Moderator SC and LS Forums

1992 SC 300 - 142K

- third owner, bought the car with 60K

- Mods: lowered 1.5 inches, 95 SC 400 wheels

- Problems:

-- power steering hose (not the pump) leaked. the hose cost $900 to replace and fix, since it was one of those steel tube type hoses

-- since the power steering fluid was leaking, it caused the alternator to go ou, which was another $800

-- driver's side window regulator went out - dealer fixed for about $225

-- high beams are stuck on - so i took the lightbulbs out

-- instrument cluster needles are out (1-2 of them)

-- climate control has middle light out

these problems have been over the course of 7 years, so it isn't as bad as it sounds. the car still runs very well.

www.bitchsessions.net

Share this post


Link to post
Share on other sites

2003 SC430 purchased new from Longo Lexus

I bought the car in 2003 April. Everything's great, except for the driver side tweeter. I noticed that the sound quality is awful when I listen to talk radio. It is very staticky and scratchy at times. unfortunately, the problem is intermittent, and of course, as soon as I take my car in to the dealer it "behaves," and I look like an idiot. Not being able to detect problem, Longo first tried padding the speaker, which did not help. They also tried taking the thing apart to see if that would help locate the cause, to no avail. The car's warranty covers all costs.

I wonder how many 2003 sc430 owners face similar problems - I doubt it, as I was told that the audio system we have is top notch if not the best currently available in the market.

Share this post


Link to post
Share on other sites
2003 SC430 purchased new from Longo Lexus

I bought the car in 2003 April. Everything's great, except for the driver side tweeter. I noticed that the sound quality is awful when I listen to talk radio. It is very staticky and scratchy at times. unfortunately, the problem is intermittent, and of course, as soon as I take my car in to the dealer it "behaves," and I look like an idiot. Not being able to detect problem, Longo first tried padding the speaker, which did not help. They also tried taking the thing apart to see if that would help locate the cause, to no avail. The car's warranty covers all costs.

I wonder how many 2003 sc430 owners face similar problems - I doubt it, as I was told that the audio system we have is top notch if not the best currently available in the market.

i have an 02 SC430. I have a "vibration" niose in my passenger midtone speaker. it only wakes up during deep tones on talk radio. the service manager at Fremont Lexus says that this is a known problem with this sound system, and that there is nothing they can do about it. This is the same guy who has tried to fix a passenger side door rattle (cooincidentally, sounds like it is coming from behind the midtone speaker) 4 times, and can't fix it. since it is intermitent, it always is quiet during my post service test rides, but soon after they turn me loose, it wakes up again. I have called Lexus North America, and they just send me back to this same service manager. I am living with both noises, but curse Lexus everytime these noises wake up.

Share this post


Link to post
Share on other sites

1992 SC300 5spd

170k miles, I bought it from New Mexico and took it to phoenix, az. 2nd owner.

Mods: Vertex Body kit, Tein coilovers, Lamborghini doors (vertical doors), Supra Targa Top, Momo stickshift, steering wheel, and handbrake. Sparco Gas cap.

Engine runs awesome.

Problems: the CD Changer not working, trunk shocks. i have to redo the upholstry, and in feb. 2005 i'm ordering the 1jzgtte motor to drop in this baby.

Let me know if anybody is interested in buying it. Make offer

doubleimagemotorsports@hotmail.com

Share this post


Link to post
Share on other sites

I have a 95 SC400

It is pretty much all stock.

No major problems.

But there is one thing that is bugging the heck out of me and no one seems to know exactly what the problem is.

It involves the climate control. The Heater Fan is always on full speed, even when you lower it the display will show 1, 2, 3 etc. but the blower will still go at full speed (Which is pretty loud and not necessary under normal weather conditions).

Once in awhile the blower will kick down to a lower speed for a few seconds, but will then go back to full blast!

Does anyone know what the heck is going on here?

Any help would be much appreciated, Thanks.

Share this post


Link to post
Share on other sites
Just bought a 1992 SC400 w/ 159k for $5,000 through ebay. This will be my project/fun car while I drive my '00 RX300. Been pouring money into it ever since trying to get it to where I want it. Here's the list.

Problems:

Excessive road noise - replaced transmission mount and drive shaft bushings and some shifter parts

Electrical problem - dim lights and radio would shut off when brakes applied (fairly common). Replaced negative battery cable, installed new battery and a grounding kit

Gauge needles-will be sending to Lextech for new needles and backlight

leather seats-replaced w/ seats from 97 SC400 (RIP)

Oil leak - Crank seal went, had to replace timing belt (again)

trunk support struts replaced

yellowed headlights-cleaned and polished  :D

Maintenance:

Oil change, transmission fluid change (Type T-IV of course), NGK Iridium plugs, wires, caps/rotors, fuel filter

Mods/upgrades:

18" HPRacing HPR5's w/ 245/45/18 tires

replaced K&N cone filter kit with BFI (definitely the way to go) 

Kenwood double din CD/Tape Headunit upgrade w/ 1/2 din storage tray for filler

Brushed aluminum dash kit

More to come......Does it ever stop?!!

I am also fitting a 2Din Kenwood headunit and have been searching for a 1/2Din storage tray for filler below. Could you please let me know where you found yours and perhaps send or post a photo of your set up. Many thanks

Share this post


Link to post
Share on other sites

1995 sc300

10,000 (in 2003) w/ 80,000K

Mods:

Supra bilstein shocks

Supra Eibach pro-kit

18" ADR formula 5 rims (235/40 pirelli Pzero-nero M&S)

nakamichi cd400 head unit

nakamichi PA 506 6ch amp

Diamond audio s500 hex component speakers

boxed 10" imade dynamic V3 sub

Share this post


Link to post
Share on other sites

plz help

i have a 1997 sc300 2jz-ge

i replaced the cats with a high flow header and exaust.

CEL says o2 sesors

if i reset my ECU my car runs fine

once CEL comes on my car runs like *BLEEP*

unless @ WOT

this makes daily driving a !Removed!

both before cat 02 sensors are new

the guy that exaust removed the rear sensors and used a modual from HP racing

CAN THE LACK OF RESISTANCE IN THE HEATING ELEMENTOF THE O2 SENSOR TRIP THE CEL AND CAUSE ALL THIS?

if so how much resistance do i need

PLZ HELP

i will be forever greatfull

Share this post


Link to post
Share on other sites

Hello,

Just purchased 1/22/05. 92 model. Has 106K on it. It was Grandma's car when I bought it. It's super clean with grey interior. Now has 18x8.5 & 18x9.5 Hp evos, Eibachs, TRD sway bars, JIC strut brace, Tokico HPs, Injen intake, Borlas, Daizen bushings. I'm still wrangling over replacing the Nak with an Alpine, but I've never had a stock system sound so good. Also thinking 3" cat. Since I'm an ASE certified Master Tech (I hold 15 certs), I never take it anywhere but my garage (Ok wheel alignments and tint I don't do). This is my 3rd Toyota and first luxury car. I'm a former Vette freak, and I don't see going back anytime soon. I like driving a car that doesn't fall apart around you!

Share this post


Link to post
Share on other sites

Hi about a year ago I bought a 92 SC300 It currantly has 160,000 miles on it. For the most part i love my car, but recently I have run into a problem that is driving me insane. My Car has developed a habit of ideling rough and sometimes stalling out when cranked. The car put a code showing that the MAF sensor was bad. So 600$ later i replaced the part. Didn't change a thing. Trying to discover whats wrong without being at the overpriced mercy of The Lexus Dealership is enough to make you crazy! :wacko:

As of current I have added an Injen Air Intake, Lowered the car using Eibocks pro kit, Added a set of Motegi FF5 wheels.

Future Plans include Borla pipes, Lextech gauges, Full stereo, and maby one day a engine swap for something w/ twin turbo.

Share this post


Link to post
Share on other sites

Hi just bought a 1998 SC300 for $13,500.00 it has 48,000 miles on it. Carfax showed two previous owners and no issues. I purchased it from the second owner. I had the Lexus dealer check it out prior to purchase. The Dealer indicated the car needed rear breaks and a serpentine(sp?) belt.

I had my local master mechanic replace the breaks and rear rotors ($87 each rotor) I for got what the breaks cost but total job was $287.00 and the serpentine belt was under $50.00 no instillation charged.

While there I had him flush the tranny clean the screen and magnet and put in toyota type t4 fluid I bought the t4 fluid(about $4 a quart) he charged me $50 to flush and clean the screen, and magnet, he charged me $9.00 for the cleaner.

He replaced the diffrential fluid with mobil 1 75/90weight I bought the fluid he flushed the diffrential and put in the two quarts of the mobil 1 around $15.00 for fluid $25.00 to install new fluid.

He flushed the power steering and replaced with power steering fluid, and cleaned both screens (in pump and sensor) $75.00, he replaced break fluid $70.00 and coolent $50.00.

This was done on his time off the books. Laddy did I tell you I am Scotish.

I detailed the interior myself using Lexol cleaner and conditioner on the leather $8.00 each bottle. I used scotch gard cleaner on spots on the head liner cost -0-. meguire vinyl conditioner/cleaner another $8.00. I will clean the rugs(look clean) in the spring and replace the floor mats.

I will replace the timing belt at 60,000 mi.

Scott

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now