AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


dude7707

Regular Member
  • Content count

    8
  • Joined

  • Last visited

  • Days Won

    2

dude7707 last won the day on July 14

dude7707 had the most liked content!

Community Reputation

1 Neutral

About dude7707

  • Rank
    New Club Member

Profile Information

  • Lexus Model
    ES300
  1. Anyone know best way to repair 2002 Lexus ES300 Rear Mark Levinson speaker - Heard Simply Speakers has a repair foam kit. Just wondering how easy is it to remove original speaker and install this kit?
  2. You ever determine what the procedure was to silicone the speaker?
  3. Hi Randy,

    please send a copy of photos and quicktime video of your speaker repair.

    I Have 2002 Lexus ES00 with ML rear speaker issue!

    Thanks for your time....assuming you still have these items above!

    kbwing@comcast.net

  4. Update: Called Toyota dealer and he quoted me $750 but no need to do now since they don't have to be replaced until 90k so hold off for a least 2 years......so I will bring the car HOME! Yes there is always the chance but most mechanics tell me that would be rare......
  5. Same issue just more money! Have 2002 ES300 with 35,612 miles went to Lexus dealer and they recommend I change timing belt due to time rather than miles....quoted me $998. Will try a Toyota dealer to compare! Anyone else been recommended to change TB with low miles but 7+ years? For most part, car has been garaged however last 6 months been parked outside...I'm sure the outside weather will probably play a factor in life of the TB......Yes?
  6. 2002 ES300 - Original Owner - 10/16/02 $43,665 from Bellevue, WA Fully Loaded: Purchased NAV/Mark Levinson Audio Package Chrome Wheels and tires - Originally $1,700 Problems: 1. Had defective rotors so Lexus replaced them No Charge within 1st year 2. Discovered within last Jan 2009 1 wheel has severe "bead Leak" took into Discount Tire...recommends replacing chrome wheel...so far just been keeping PSI at 35 for each tire...ok.....except for RR wheel....will check with another 3rd party to see if it can be fixed. According to DT the chrome finish is flaking off causing it to not be a good fit between tire and wheel. Called Lexus and they offered $300 credit towards next service call....better than nothing but seems minimal since the same wheels today cost $850 ea. Refurbished through the net costs $450 ea. Age: 53 Insurance: Allstate - Annual Premiums - $654 - $1,000 deductible on Collision/Comp and No Rental or Towing. Other than items noted above still in fairly good condition....some wear and tear on front driver's seat. Current OD 35, 569 After 1st 5k free Lexus service calls just had annual oil changes with Toyota dealer...alot cheaper than going through Lexus dealer. So far no other issues at this time!
  7. Update: Apears the water was low in the battery, so added some, put the charger on it and appears to be ok. Will check it tomorrow to see if it still starts! Something else must be going on since I can't believe just listening to my stereo for an hour or so would cause the battery to discharge that much...unless of course I have a defective battery!
  8. How about this challenge!!!!!!!!! 2002 ES300 - Just listening to my stereo and cleaning the interior when I was using a rag to clean the R Side I believe are the SRS airbag panel when the stereo began going off and now when I try starting the car it just clicks. The dashboard lights up but my Nav system display flickers and then goes out. I purchased a new battery back in 11/07 so will trying jumping first and hope this works. Any other thoughts....help! :o
  9. Just told my 2002 ES300 with 9 spoke 16in chrome wheel has bead leak and should be replaced - Per Discount Tires. Checked w/Fife Lexus - $793/wheel w/o tax! They suggested ebay or craigslist...... As far as I know, wheel has not been hit...they tell me its the chrome coming off and falling within the bead. Anyone else had this issue?