AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




Btrini

Regular Member
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Btrini

  • Rank
    New Club Member

Contact Methods

  • First Name
    Brian

Profile Information

  • Lexus Model
    LX 570
  • Lexus Year
    2014
  • Location
    North Carolina (NC)
  1. That's the thing. What's considered a high failure rate. The issue is not isolated to the LX. On other forums and sites like repair pal there are a lot of complaints. One site shows complaints as far back as 2001 vehicles. I called United radio, who a lot of owners use to repair the amp and while they could not share how many repairs they got from Lexus owners grey did confirm that it is fairly often. This is sounding like a common issue to me. Even the dealer I took it to kinda confirmed that.
  2. Has anyone contacted Lexus and ask why this is not a recall. It seems to be a common issue.
  3. Mark Levinson Amplifier

    6 months ago I purchased a Certified Pre Owned LX 570 and have been loving it so far. However, yesterday the sound suddenly cut off while I was driving. Did some reading and found that these Mark Levinson amplifiers have been acting up since 2001 vehicles. I took the vehicle to the dealer and confirmed that the issue was the amplifier and enquired as to why haven't Lexus done anything about this issue which seems to be over 16 years old. I spoke to someone and they suggested there may be ground for a class action lawsuit based on the number of vehicles that have had this issue. I am curious as to how many have had this problem to see if there is indeed a systematic issue or if they are isolated incidents. Look forward to hearing back. Thanks