AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




fljjmarz

Regular Member
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About fljjmarz

  • Rank
    New Club Member

Contact Methods

  • First Name
    Frank

Profile Information

  • Lexus Model
    ES350
  • Lexus Year
    2007
  • Location
    New Jersey (NJ)
  1. Anti-Lock Brakes Issue

    Just wanted to post a follow up on this issue I was having in case anyone else had the same issue down the road. I brought the car to my mechanic who couldn’t figure out the problem, because no codes were coming up. He in turn took the car to another shop, to have them test the brake system with some special equipment and it turned out I had a bad ABS Front Driver Side Wheel Speed Sensor. My mechanic wanted to install an original part costing upwards of $170, and charge me an hour of labor at roughly $90…I told him to forget it, I’d see if I could get the part cheaper. I purchased a Chinese knockoff of the part on EBay for less than $15, and had it installed in about an hour. I installed it over the weekend and haven’t had the issue since. Hope this helps someone down the road. Thanks for the replies/ideas/suggestions. Frank
  2. Anti-Lock Brakes Issue

    I’ve recently noticed an issue with the anti-lock brakes in my 2007 ES350. As I’m coming to a stop, in all road and weather conditions, the anti-lock brakes seem to be activating for a couple pulses, when it’s completely unnecessary. This only seems to be happens when I’m coming to a stop, from a relatively slow speed, like if I’m driving around town at approximately 25mph, and apply the brakes to stop at a traffic light or stop sign. I don’t seem to have this issue when I’m coming to a more abrupt stop or coming to a stop from a faster speed. I also noticed that if I’m coming to a stop, and preparing for a left turn, it almost always happens, but if I’m stopping and preparing to turn right it seem to happen less frequent. I’m posting here because I’m hoping someone has experienced the same issue and can point me in the right direction. Any suggestions/ideas as to what could be causing this issue would be greatly appreciated. Thanks in advance. Frank