AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




All Activity

This stream auto-updates     

  1. Today
  2. NAV SCREEN FROZEN WHITE

    I tried that but unfortunately didn't work still
  3. Yesterday
  4. I have same problem. I took the car to Lexus dealer and they say AF sensors are not communicating with the ECU. Recommended replacing the brand new Denso sensors and if that doesn't work replace Co2 sensor which I did. I also put in a new OEM MAF. Nothing has helped! I am thinking about replacing the sensor on the throttle body to see if that helps. My mechanic said he could not find any vacuum leaks. He did say there was a very small leak in the throttle body but didn't think that would cause my problem. Any help or ideas will be appreciated.
  5. 98 LS400 Instrument Panel/Gauges

    Tanin actually has a storefront on Ebay. They have refurbished whole instrument clusters for $699 or repairs ranging from $150 - 699. Ideally I'd like to keep my original cluster so I can keep the original mileage intact while fixing the faulty gauge readings.
  6. Water Pump

    I understand YOU completely, with bad paint, I would sell Soon too.. glad no one was hurt..
  7. 5 RELAYS BLEW SOS

    Also if anyone lives in Los Angeles area that's interested in a 99 ls400 I'm selling this one for dirt cheap it's a black with grey paint on the outside black leather on inside with wood trim
  8. 5 RELAYS BLEW SOS

    I changed the battery on Sunday and before everyone says I put it on backwards I'm not an idiot and know negative and positive so I changed the battery and the terminals because when I bought the car they were all !Removed! up. So I changed the battery in the parking lot of an autozone and when I finished I got back in and drove home everything was perfect I drove the car like 5 times later that day and the next day on Monday I went to work and when I got off I heard the noise that fuses make when they pop and lost all power to anything. I checked the fuse box and the fuses were fine but 5 of the relays were toasted. Does anyone have any idea where to start checking for shorts or anything since I have no knowledge on electricity
  9. 98 LS400 Instrument Panel/Gauges

    Seems like you and I are experiencing the same issue on our 98's. Does your trip computer work to show you how many miles are left until empty? Mine works. It is strictly the fuel gauge that is showing more gas than what is actually present. I'm under the assumption now that it is the instrumentation cluster. Does your temp gauge read above the middle when the engine is warm? The circuit plate you mention retails for over $900! And the labor to have it put in if it is too difficult for self repair
  10. I have the same problem. I have replaced all 3 sensors with OEM and MAF. I had Toyota and the Lexus dealer check the problem. They say AF sensors (brand new OEM) not reading and no communication between sensors and ECU. I am still getting codes and car is burning gas like crazy. My mechanic checked for vacuum leaks and found none. I am wondering if it might be the sensor on the throttle body. My mechanic said there is a very small vacuum leak with throttle body but doesen't think that would cause the problem I'm having. Any help would be appreciated!
  11. Water Pump

    I have 154K on the car. The belt was done at 90K. The water pump was replaced at 50K (before I got it). I've owned since 70K. I agree, typically do the pump, cam and crank seals along with the belt. The clear coat is eroding on the roof and starting on the hood. The driver's seat has tears and I need something that looks better. Jade mica with a tan interior. I plan to sell after the repair. I have to look into pricing. Orlando. Lost power for 5 days and weakened my wooden fence for the backyard. We were very fortunate, and I am ever so grateful. Thank you for your guidance.
  12. 98 LS400 Instrument Panel/Gauges

    TRY THIS: www.taninautoelectronix.com but try it at your own risk,, they have had many complaints AND some "thank yous " get your issue settled read: https://www.clublexus.com/forums/ls-1st-and-2nd-gen-1990-2000/862968-91-ls-400-instrument-cluster-fuse-keeps-blowing.html
  13. Water Pump

    NO and I hope you are doing the timing belt and other bearings in the front of your engine.. what part of Florida are you in? did the storm get to you??
  14. Water Pump

    Hello All, Is there a "better" aftermarket water pump brand that is more compatible for the 2000 LS400? Quite certain of noise from the bearing on mine. Sending it to an independent Tuesday AM. My first time using this company.
  15. 98 LS400 Instrument Panel/Gauges

    I do however wonder how does it get reprogrammed to have the correct mileage and etc.
  16. 98 LS400 Instrument Panel/Gauges

    I see. Yes I called the dealer to confirm yesterday and the part they gave was the computer meter plate that is essentially a part of the instrument cluster. Lexus Part No.: 83277-50190 PLATE,COMPUTER METER CIRCUIT NO.1 Might as well purchase the entire cluster vs. Paying $1300 just for the circuit board.
  17. 98 LS400 Instrument Panel/Gauges

    Mine has the same problem. The gas meter shows more gas than what is really in the tank. I replaced the fuel sender located in the tank but that didn't fix the problem which was very disappointing. My next guess is the instrument cluster.
  18. Last week
  19. My 1998 LS400 had fully functioning fuel gauge until one day this past week I noticed it stayed full beyond what it should have. Towards the end of the tank it dropped to half. I just replaced the fuel sender with a brand new OEM and the fuel marker stayed at half even though the tank was mostly empty. I am puzzled and frankly not sure what to do anymore. I don't want to spend a fortune fixing the instrumentation cluster and see the problem still persisting. Fortunately the trip computer seems to be working so I have a good idea when the gas tank is getting low. Actually a little annoyed cause the original fuel sender is probably working fine. fuelsender
  20. Delete Account Or Change Username

    Please delete my account, so I can re-create it with a new username and current info.
  21. 98 LS400 Instrument Panel/Gauges

    Is this what you need?
  22. Car wont start '98 LS 400

    M.Yasir, I think the codes could happen to occur when a car does not start and one tries to crank it over. When the car could not start up at all, I think the ECM was thrown a bunch of incomplete messages (reports) and result a bunch of bad reports. It happened to me once when my car did not start and reading codes gave me a long list (O2 sensor, ... you name it). But it was MAF problem. I replaced it, reset all the codes and it was fine.
  23. 98 LS400 Instrument Panel/Gauges

    This is what the dealer explained to me as the fix. Informed that my fuel gauge is reading more gas than what is actually in the tank, thus I have been driving with far less gas frequently impacting the fuel pump. They replaced the fuel pump and identified the issue at that time. The entire gauge cluster would need to be replaced to fix the issue with the fuel reading.
  24. Car wont start '98 LS 400

    I had the same problem. Click once or twice each time I turned the key. After 7-8 tries it would finally start. I found a remanufactured Denso starter for $129 on Amazon and paid a mechanic who said it was a strenuous job 5 labor hours to put it in. Car starts great now.
  25. 98 LS400 vibration above 72 mph

    I had the same issue on my 1998. Previous owner had cheap tires. I had those balanced but still vibrated a little. I put new Michelins and it went away. I noticed though going 95 MPH or more the car would shake. Make sure your tire pressure is around 34/35 PSI. I had mine at the in car panel recommendation of 29 which is fine for slow driving but not for highway. High speed needs firmer tires.
  26. 98 LS400 Instrument Panel/Gauges

    What do you mean by "fuel sensor"? I am experiencing issues with my fuel gauge showing high gas reading when I know for a fact my gas tank has far less on my 1998 LS400. I just bought an OEM fuel sender but after reading some posts I'm skeptical this might fix my problem. Dealer wanted $850 to replace fuel sender. I found an OEM part for $138.
  27. ALTERNATOR NOT CHARGING THE BATTERY

    This is an old post. I think you fixed it by replacing the alternator or fixing the connectivity. Battery is charged with higher voltage than 12.3V.
  1. Load more activity